summaryrefslogtreecommitdiff
path: root/python-queueman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-queueman.spec')
-rw-r--r--python-queueman.spec126
1 files changed, 126 insertions, 0 deletions
diff --git a/python-queueman.spec b/python-queueman.spec
new file mode 100644
index 0000000..52a19cf
--- /dev/null
+++ b/python-queueman.spec
@@ -0,0 +1,126 @@
+%global _empty_manifest_terminate_build 0
+Name: python-queueman
+Version: 0.5
+Release: 1
+Summary: please add a summary manually as the author left a blank one
+License: MIT License
+URL: https://github.com/ludeeus/queueman
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d4/83/f6ad88f2c5938462f9109447a8088876f5f9a3f5e2576fd970485c6a44c3/queueman-0.5.tar.gz
+BuildArch: noarch
+
+
+%description
+# Queue manager
+
+[![codecov][codecov_img]][codecov_url]
+[![Test action][github_action_test]][github_actions]
+
+WIP
+
+```bash
+python3 -m pip install queueman
+```
+
+<!-- LINKS -->
+[codecov_url]: https://codecov.io/gh/ludeeus/queueman
+[codecov_img]: https://codecov.io/gh/ludeeus/queueman/branch/master/graph/badge.svg
+[github_actions]: https://github.com/ludeeus/queueman/actions
+[github_action_test]: https://github.com/ludeeus/queueman/workflows/Test/badge.svg
+<!-- LINKS -->
+
+
+
+%package -n python3-queueman
+Summary: please add a summary manually as the author left a blank one
+Provides: python-queueman
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-queueman
+# Queue manager
+
+[![codecov][codecov_img]][codecov_url]
+[![Test action][github_action_test]][github_actions]
+
+WIP
+
+```bash
+python3 -m pip install queueman
+```
+
+<!-- LINKS -->
+[codecov_url]: https://codecov.io/gh/ludeeus/queueman
+[codecov_img]: https://codecov.io/gh/ludeeus/queueman/branch/master/graph/badge.svg
+[github_actions]: https://github.com/ludeeus/queueman/actions
+[github_action_test]: https://github.com/ludeeus/queueman/workflows/Test/badge.svg
+<!-- LINKS -->
+
+
+
+%package help
+Summary: Development documents and examples for queueman
+Provides: python3-queueman-doc
+%description help
+# Queue manager
+
+[![codecov][codecov_img]][codecov_url]
+[![Test action][github_action_test]][github_actions]
+
+WIP
+
+```bash
+python3 -m pip install queueman
+```
+
+<!-- LINKS -->
+[codecov_url]: https://codecov.io/gh/ludeeus/queueman
+[codecov_img]: https://codecov.io/gh/ludeeus/queueman/branch/master/graph/badge.svg
+[github_actions]: https://github.com/ludeeus/queueman/actions
+[github_action_test]: https://github.com/ludeeus/queueman/workflows/Test/badge.svg
+<!-- LINKS -->
+
+
+
+%prep
+%autosetup -n queueman-0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-queueman -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5-1
+- Package Spec generated