summaryrefslogtreecommitdiff
path: root/python-ranger.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ranger.spec')
-rw-r--r--python-ranger.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-ranger.spec b/python-ranger.spec
new file mode 100644
index 0000000..77a0dbe
--- /dev/null
+++ b/python-ranger.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ranger
+Version: 0.10
+Release: 1
+Summary: A Python package for the manipulation of Range objects
+License: BSD
+URL: https://github.com/er432/Ranger
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f5/0f/8221ba0ad0a5917011d4e32cb41edeb5ebdd8b36888a75cb0a8fc55151d7/ranger-0.10.tar.gz
+BuildArch: noarch
+
+
+%description
+Ranger is a Python package for the manipulation of range objects.
+Ranges may extend over discrete or continuous domains, be open or closed,
+bounded or unbounded. Ranger also includes tools for managing collections
+ of ranges, which may be mapped to other objects.
+
+%package -n python3-ranger
+Summary: A Python package for the manipulation of Range objects
+Provides: python-ranger
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ranger
+Ranger is a Python package for the manipulation of range objects.
+Ranges may extend over discrete or continuous domains, be open or closed,
+bounded or unbounded. Ranger also includes tools for managing collections
+ of ranges, which may be mapped to other objects.
+
+%package help
+Summary: Development documents and examples for ranger
+Provides: python3-ranger-doc
+%description help
+Ranger is a Python package for the manipulation of range objects.
+Ranges may extend over discrete or continuous domains, be open or closed,
+bounded or unbounded. Ranger also includes tools for managing collections
+ of ranges, which may be mapped to other objects.
+
+%prep
+%autosetup -n ranger-0.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ranger -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10-1
+- Package Spec generated