summaryrefslogtreecommitdiff
path: root/python-rbcl.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:30:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:30:32 +0000
commitc236d38c9c4df51d584586dbf2b6636e19466baf (patch)
tree0a5a952febbb3546af42389c3c11f1151a5865fa /python-rbcl.spec
parent3556c17f1e09ac6de174ab53516487b9ad4b0d6a (diff)
automatic import of python-rbcl
Diffstat (limited to 'python-rbcl.spec')
-rw-r--r--python-rbcl.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-rbcl.spec b/python-rbcl.spec
new file mode 100644
index 0000000..c4bf074
--- /dev/null
+++ b/python-rbcl.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-rbcl
+Version: 1.0.1
+Release: 1
+Summary: Python library that bundles libsodium and provides wrappers for its Ristretto group functions.
+License: MIT
+URL: https://github.com/nthparty/rbcl
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d7/cc/d0a762fe04307cb90dabeed2e0349639761fc37c4ef09d4b8e7f9648b1e8/rbcl-1.0.1.tar.gz
+
+Requires: python3-barriers
+Requires: python3-setuptools
+Requires: python3-wheel
+Requires: python3-pystache
+Requires: python3-build
+Requires: python3-coveralls
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-pylint
+Requires: python3-twine
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+
+
+%package -n python3-rbcl
+Summary: Python library that bundles libsodium and provides wrappers for its Ristretto group functions.
+Provides: python-rbcl
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-rbcl
+
+
+%package help
+Summary: Development documents and examples for rbcl
+Provides: python3-rbcl-doc
+%description help
+
+
+%prep
+%autosetup -n rbcl-1.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-rbcl -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
+- Package Spec generated