summaryrefslogtreecommitdiff
path: root/python-recursivefeatureselector.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 12:02:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 12:02:25 +0000
commit690e3bab064521d5907792ec723a1dfac6720ee7 (patch)
tree91d7cf14969cf5b1cc51c2d5d5f11425a33284b7 /python-recursivefeatureselector.spec
parent68739b0d101a82ef7fa5279828039a79c4951248 (diff)
automatic import of python-recursivefeatureselector
Diffstat (limited to 'python-recursivefeatureselector.spec')
-rw-r--r--python-recursivefeatureselector.spec192
1 files changed, 192 insertions, 0 deletions
diff --git a/python-recursivefeatureselector.spec b/python-recursivefeatureselector.spec
new file mode 100644
index 0000000..a349af6
--- /dev/null
+++ b/python-recursivefeatureselector.spec
@@ -0,0 +1,192 @@
+%global _empty_manifest_terminate_build 0
+Name: python-RecursiveFeatureSelector
+Version: 1.3.8
+Release: 1
+Summary: Recursively selecting features for machine learning task.
+License: MIT
+URL: https://github.com/HindyDS/RecursiveFeatureSelector
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/33/3d9bb6f0a502044f13625d8d8a9ae79dbccf9ea004d476ce28753b970afb/RecursiveFeatureSelector-1.3.8.tar.gz
+BuildArch: noarch
+
+
+%description
+# <img src="https://raw.githubusercontent.com/HindyDS/RecursiveFeatureSelector/main/logo/RFS%2010.5.2021.png" height="277">
+
+[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
+[![PyPI version](https://badge.fury.io/py/RecursiveFeatureSelector.svg)](https://badge.fury.io/py/RecursiveFeatureSelector)
+[![MIT Licence](https://badges.frapsoft.com/os/mit/mit.svg?v=103)](https://opensource.org/licenses/mit-license.php)
+
+RecursiveFeatureSelector aims to select the best features or the subset of features in machine learning tasks according to corresponding score with other incredible packages like numpy, pandas and sklearn.
+
+This package is inspired by:
+PyData DC 2016 | A Practical Guide to Dimensionality Reduction
+Vishal Patel
+October 8, 2016
+
+- **Examples:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/examples
+- **Email:** hindy888@hotmail.com
+- **Source code:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/RecursiveFeatureSelector
+- **Bug reports:** https://github.com/HindyDS/RecursiveFeatureSelector/issues
+
+It requires at least six arguments to run:
+
+- estimators: machine learning model
+- X (array): features space
+- y (array): target
+- cv (int): number of folds in a (Stratified)KFold
+- scoring (str): see https://scikit-learn.org/stable/modules/model_evaluation.html
+
+Optional arguments:
+- max_trial (int): number of trials that you wanted RFS to stop searching
+- tolerance (int): how many times RFS can fail to find better subset of features
+- least_gain (int): threshold of scoring metrics gain in fraction
+- max_feats (int): maximum number of features
+- prior (list): starting point for RFS to search, must be corresponds to the columns of X
+- exclusions (nested list): if the new selected feature is in one of the particular subpool
+ (list in the nested list), then the features in that particular subpool with no longer be avalible to form any new subset in the following trials
+- n_jobs (int): Number of jobs to run in parallel.
+- n_digit (int): Decimal places for scoring
+- verbose (int): Level of verbosity of RFS
+
+If you have any ideas for this packge please don't hesitate to bring forward!
+
+
+
+%package -n python3-RecursiveFeatureSelector
+Summary: Recursively selecting features for machine learning task.
+Provides: python-RecursiveFeatureSelector
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-RecursiveFeatureSelector
+# <img src="https://raw.githubusercontent.com/HindyDS/RecursiveFeatureSelector/main/logo/RFS%2010.5.2021.png" height="277">
+
+[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
+[![PyPI version](https://badge.fury.io/py/RecursiveFeatureSelector.svg)](https://badge.fury.io/py/RecursiveFeatureSelector)
+[![MIT Licence](https://badges.frapsoft.com/os/mit/mit.svg?v=103)](https://opensource.org/licenses/mit-license.php)
+
+RecursiveFeatureSelector aims to select the best features or the subset of features in machine learning tasks according to corresponding score with other incredible packages like numpy, pandas and sklearn.
+
+This package is inspired by:
+PyData DC 2016 | A Practical Guide to Dimensionality Reduction
+Vishal Patel
+October 8, 2016
+
+- **Examples:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/examples
+- **Email:** hindy888@hotmail.com
+- **Source code:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/RecursiveFeatureSelector
+- **Bug reports:** https://github.com/HindyDS/RecursiveFeatureSelector/issues
+
+It requires at least six arguments to run:
+
+- estimators: machine learning model
+- X (array): features space
+- y (array): target
+- cv (int): number of folds in a (Stratified)KFold
+- scoring (str): see https://scikit-learn.org/stable/modules/model_evaluation.html
+
+Optional arguments:
+- max_trial (int): number of trials that you wanted RFS to stop searching
+- tolerance (int): how many times RFS can fail to find better subset of features
+- least_gain (int): threshold of scoring metrics gain in fraction
+- max_feats (int): maximum number of features
+- prior (list): starting point for RFS to search, must be corresponds to the columns of X
+- exclusions (nested list): if the new selected feature is in one of the particular subpool
+ (list in the nested list), then the features in that particular subpool with no longer be avalible to form any new subset in the following trials
+- n_jobs (int): Number of jobs to run in parallel.
+- n_digit (int): Decimal places for scoring
+- verbose (int): Level of verbosity of RFS
+
+If you have any ideas for this packge please don't hesitate to bring forward!
+
+
+
+%package help
+Summary: Development documents and examples for RecursiveFeatureSelector
+Provides: python3-RecursiveFeatureSelector-doc
+%description help
+# <img src="https://raw.githubusercontent.com/HindyDS/RecursiveFeatureSelector/main/logo/RFS%2010.5.2021.png" height="277">
+
+[![Open Source Love](https://badges.frapsoft.com/os/v2/open-source.svg?v=103)](https://github.com/ellerbrock/open-source-badges/)
+[![PyPI version](https://badge.fury.io/py/RecursiveFeatureSelector.svg)](https://badge.fury.io/py/RecursiveFeatureSelector)
+[![MIT Licence](https://badges.frapsoft.com/os/mit/mit.svg?v=103)](https://opensource.org/licenses/mit-license.php)
+
+RecursiveFeatureSelector aims to select the best features or the subset of features in machine learning tasks according to corresponding score with other incredible packages like numpy, pandas and sklearn.
+
+This package is inspired by:
+PyData DC 2016 | A Practical Guide to Dimensionality Reduction
+Vishal Patel
+October 8, 2016
+
+- **Examples:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/examples
+- **Email:** hindy888@hotmail.com
+- **Source code:** https://github.com/HindyDS/RecursiveFeatureSelector/tree/main/RecursiveFeatureSelector
+- **Bug reports:** https://github.com/HindyDS/RecursiveFeatureSelector/issues
+
+It requires at least six arguments to run:
+
+- estimators: machine learning model
+- X (array): features space
+- y (array): target
+- cv (int): number of folds in a (Stratified)KFold
+- scoring (str): see https://scikit-learn.org/stable/modules/model_evaluation.html
+
+Optional arguments:
+- max_trial (int): number of trials that you wanted RFS to stop searching
+- tolerance (int): how many times RFS can fail to find better subset of features
+- least_gain (int): threshold of scoring metrics gain in fraction
+- max_feats (int): maximum number of features
+- prior (list): starting point for RFS to search, must be corresponds to the columns of X
+- exclusions (nested list): if the new selected feature is in one of the particular subpool
+ (list in the nested list), then the features in that particular subpool with no longer be avalible to form any new subset in the following trials
+- n_jobs (int): Number of jobs to run in parallel.
+- n_digit (int): Decimal places for scoring
+- verbose (int): Level of verbosity of RFS
+
+If you have any ideas for this packge please don't hesitate to bring forward!
+
+
+
+%prep
+%autosetup -n RecursiveFeatureSelector-1.3.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-RecursiveFeatureSelector -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.8-1
+- Package Spec generated