summaryrefslogtreecommitdiff
path: root/python-redis-collections.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 07:11:54 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 07:11:54 +0000
commit7f26ec52ba0424583c5ade9ddf21c4d6bb6dfd40 (patch)
tree3a57c6b608b0474d18d6129662b71c08dc0e020d /python-redis-collections.spec
parenta2942f8f4e28f7fb6e1f692caa1d8431cc32e580 (diff)
automatic import of python-redis-collections
Diffstat (limited to 'python-redis-collections.spec')
-rw-r--r--python-redis-collections.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-redis-collections.spec b/python-redis-collections.spec
new file mode 100644
index 0000000..9815614
--- /dev/null
+++ b/python-redis-collections.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-redis-collections
+Version: 0.11.0
+Release: 1
+Summary: Set of basic Python collections backed by Redis.
+License: ISC
+URL: https://github.com/redis-collections/redis-collections
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fe/ab/2c0a3fbb53b4d6da932207e227377a218c47a33695f7880bafc91007e4d1/redis-collections-0.11.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-redis
+
+%description
+`redis-collections` is a Python library that provides a high-level
+interface to `Redis <http://redis.io/>`_, the excellent key-value store.
+
+%package -n python3-redis-collections
+Summary: Set of basic Python collections backed by Redis.
+Provides: python-redis-collections
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-redis-collections
+`redis-collections` is a Python library that provides a high-level
+interface to `Redis <http://redis.io/>`_, the excellent key-value store.
+
+%package help
+Summary: Development documents and examples for redis-collections
+Provides: python3-redis-collections-doc
+%description help
+`redis-collections` is a Python library that provides a high-level
+interface to `Redis <http://redis.io/>`_, the excellent key-value store.
+
+%prep
+%autosetup -n redis-collections-0.11.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-redis-collections -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.11.0-1
+- Package Spec generated