summaryrefslogtreecommitdiff
path: root/python-replit.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 09:11:28 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 09:11:28 +0000
commit47ecee300dd48477b82860b9c76835724718394a (patch)
tree4b858c12680abca8ac2c58e4cfbd55e421b4950e /python-replit.spec
parent4e9418884bcb54abc7f4b63b6a240010f7fa7335 (diff)
automatic import of python-replit
Diffstat (limited to 'python-replit.spec')
-rw-r--r--python-replit.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-replit.spec b/python-replit.spec
new file mode 100644
index 0000000..8aac04d
--- /dev/null
+++ b/python-replit.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-replit
+Version: 3.2.5
+Release: 1
+Summary: A library for interacting with features of repl.it
+License: ISC
+URL: https://github.com/replit/replit-py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5f/35/214766f7a4ca1ddb2e8b4c70902a54fb2c1e3a812507a5370392d4c81665/replit-3.2.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-typing_extensions
+Requires: python3-Flask
+Requires: python3-Werkzeug
+Requires: python3-aiohttp
+Requires: python3-requests
+Requires: python3-pyseto
+Requires: python3-protobuf
+
+%description
+### `>>> import replit`
+
+![compute](https://github.com/kennethreitz42/replit-py/blob/kr-cleanup/ext/readme.gif?raw=true)
+
+This repository is the home for the `replit` Python package, which provides:
+
+- A fully-featured database client for [Replit DB](https://docs.repl.it/misc/database).
+- A Flask–based application framework for accelerating development on the platform.
+- Replit user profile metadata retrieval (more coming here!).
+- A simple audio library that can play tones and audio files!
+
+### Open Source License
+
+This library is licensed under the [ISC License](https://en.wikipedia.org/wiki/ISC_license) and is free for you to use, change, or even profit from!
+
+
+%package -n python3-replit
+Summary: A library for interacting with features of repl.it
+Provides: python-replit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-replit
+### `>>> import replit`
+
+![compute](https://github.com/kennethreitz42/replit-py/blob/kr-cleanup/ext/readme.gif?raw=true)
+
+This repository is the home for the `replit` Python package, which provides:
+
+- A fully-featured database client for [Replit DB](https://docs.repl.it/misc/database).
+- A Flask–based application framework for accelerating development on the platform.
+- Replit user profile metadata retrieval (more coming here!).
+- A simple audio library that can play tones and audio files!
+
+### Open Source License
+
+This library is licensed under the [ISC License](https://en.wikipedia.org/wiki/ISC_license) and is free for you to use, change, or even profit from!
+
+
+%package help
+Summary: Development documents and examples for replit
+Provides: python3-replit-doc
+%description help
+### `>>> import replit`
+
+![compute](https://github.com/kennethreitz42/replit-py/blob/kr-cleanup/ext/readme.gif?raw=true)
+
+This repository is the home for the `replit` Python package, which provides:
+
+- A fully-featured database client for [Replit DB](https://docs.repl.it/misc/database).
+- A Flask–based application framework for accelerating development on the platform.
+- Replit user profile metadata retrieval (more coming here!).
+- A simple audio library that can play tones and audio files!
+
+### Open Source License
+
+This library is licensed under the [ISC License](https://en.wikipedia.org/wiki/ISC_license) and is free for you to use, change, or even profit from!
+
+
+%prep
+%autosetup -n replit-3.2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-replit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.5-1
+- Package Spec generated