summaryrefslogtreecommitdiff
path: root/python-requests-oauthlib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-requests-oauthlib.spec')
-rw-r--r--python-requests-oauthlib.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-requests-oauthlib.spec b/python-requests-oauthlib.spec
new file mode 100644
index 0000000..9ac0965
--- /dev/null
+++ b/python-requests-oauthlib.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-requests-oauthlib
+Version: 1.3.1
+Release: 1
+Summary: OAuthlib authentication support for Requests.
+License: ISC
+URL: https://github.com/requests/requests-oauthlib
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/95/52/531ef197b426646f26b53815a7d2a67cb7a331ef098bb276db26a68ac49f/requests-oauthlib-1.3.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-oauthlib
+Requires: python3-requests
+Requires: python3-oauthlib[signedtoken]
+
+%description
+This project provides first-class OAuth library support for `Requests <http://python-requests.org>`_.
+
+%package -n python3-requests-oauthlib
+Summary: OAuthlib authentication support for Requests.
+Provides: python-requests-oauthlib
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-requests-oauthlib
+This project provides first-class OAuth library support for `Requests <http://python-requests.org>`_.
+
+%package help
+Summary: Development documents and examples for requests-oauthlib
+Provides: python3-requests-oauthlib-doc
+%description help
+This project provides first-class OAuth library support for `Requests <http://python-requests.org>`_.
+
+%prep
+%autosetup -n requests-oauthlib-1.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-requests-oauthlib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.1-1
+- Package Spec generated