summaryrefslogtreecommitdiff
path: root/python-rtmixer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-rtmixer.spec')
-rw-r--r--python-rtmixer.spec119
1 files changed, 119 insertions, 0 deletions
diff --git a/python-rtmixer.spec b/python-rtmixer.spec
new file mode 100644
index 0000000..bf702b0
--- /dev/null
+++ b/python-rtmixer.spec
@@ -0,0 +1,119 @@
+%global _empty_manifest_terminate_build 0
+Name: python-rtmixer
+Version: 0.1.4
+Release: 1
+Summary: Reliable low-latency audio playback and recording
+License: MIT
+URL: https://python-rtmixer.readthedocs.io/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/84/f480b9743fc88fa618bda216b79919c87c75de1e2afdd2faf24caa35a3f7/rtmixer-0.1.4.tar.gz
+
+Requires: python3-CFFI
+Requires: python3-pa-ringbuffer
+Requires: python3-sounddevice
+
+%description
+Goal: Reliable low-latency audio playback and recording with Python, using
+PortAudio_ via the sounddevice_ module.
+The audio callback is implemented in C (and compiled with the help of CFFI_)
+and doesn't invoke the Python interpreter, therefore avoiding waiting for things
+like garbage collection and the GIL.
+All PortAudio platforms and host APIs are supported.
+Runs on any Python version where CFFI is available.
+Online documentation
+ https://python-rtmixer.readthedocs.io/
+Source code repository
+ https://github.com/spatialaudio/python-rtmixer
+Somewhat similar projects
+ * https://github.com/nwhitehead/swmixer
+ * https://github.com/nvahalik/PyAudioMixer
+ * http://www.pygame.org/docs/ref/mixer.html
+
+%package -n python3-rtmixer
+Summary: Reliable low-latency audio playback and recording
+Provides: python-rtmixer
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-rtmixer
+Goal: Reliable low-latency audio playback and recording with Python, using
+PortAudio_ via the sounddevice_ module.
+The audio callback is implemented in C (and compiled with the help of CFFI_)
+and doesn't invoke the Python interpreter, therefore avoiding waiting for things
+like garbage collection and the GIL.
+All PortAudio platforms and host APIs are supported.
+Runs on any Python version where CFFI is available.
+Online documentation
+ https://python-rtmixer.readthedocs.io/
+Source code repository
+ https://github.com/spatialaudio/python-rtmixer
+Somewhat similar projects
+ * https://github.com/nwhitehead/swmixer
+ * https://github.com/nvahalik/PyAudioMixer
+ * http://www.pygame.org/docs/ref/mixer.html
+
+%package help
+Summary: Development documents and examples for rtmixer
+Provides: python3-rtmixer-doc
+%description help
+Goal: Reliable low-latency audio playback and recording with Python, using
+PortAudio_ via the sounddevice_ module.
+The audio callback is implemented in C (and compiled with the help of CFFI_)
+and doesn't invoke the Python interpreter, therefore avoiding waiting for things
+like garbage collection and the GIL.
+All PortAudio platforms and host APIs are supported.
+Runs on any Python version where CFFI is available.
+Online documentation
+ https://python-rtmixer.readthedocs.io/
+Source code repository
+ https://github.com/spatialaudio/python-rtmixer
+Somewhat similar projects
+ * https://github.com/nwhitehead/swmixer
+ * https://github.com/nvahalik/PyAudioMixer
+ * http://www.pygame.org/docs/ref/mixer.html
+
+%prep
+%autosetup -n rtmixer-0.1.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-rtmixer -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
+- Package Spec generated