summaryrefslogtreecommitdiff
path: root/python-runipy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-runipy.spec')
-rw-r--r--python-runipy.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-runipy.spec b/python-runipy.spec
new file mode 100644
index 0000000..d4c2e6b
--- /dev/null
+++ b/python-runipy.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-runipy
+Version: 0.1.5
+Release: 1
+Summary: Run IPython notebooks from the command line
+License: BSD 2-Clause
+URL: https://github.com/paulgb/runipy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ab/b7/628258778b5b6da373dda3053241bf5f7d80ee65941ad3ad219fb3e9356f/runipy-0.1.5.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-runipy
+Summary: Run IPython notebooks from the command line
+Provides: python-runipy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-runipy
+
+
+%package help
+Summary: Development documents and examples for runipy
+Provides: python3-runipy-doc
+%description help
+
+
+%prep
+%autosetup -n runipy-0.1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-runipy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
+- Package Spec generated