summaryrefslogtreecommitdiff
path: root/python-s3transfer.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 07:03:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 07:03:50 +0000
commit2ce4d7c2456084ea68eca81e0800fbca197ddcc8 (patch)
treefe63f86cb439027cacd9464153910cb31039b1be /python-s3transfer.spec
parentca43aa1844b0b343f3f3f6b59f40523492950ef3 (diff)
automatic import of python-s3transfer
Diffstat (limited to 'python-s3transfer.spec')
-rw-r--r--python-s3transfer.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-s3transfer.spec b/python-s3transfer.spec
new file mode 100644
index 0000000..b2f7a86
--- /dev/null
+++ b/python-s3transfer.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-s3transfer
+Version: 0.6.0
+Release: 1
+Summary: An Amazon S3 Transfer Manager
+License: Apache License 2.0
+URL: https://github.com/boto/s3transfer
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/eb/e57c93d5cd5edf8c1d124c831ef916601540db70acd96fa21fe60cef1365/s3transfer-0.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-botocore
+Requires: python3-botocore[crt]
+
+%description
+
+
+%package -n python3-s3transfer
+Summary: An Amazon S3 Transfer Manager
+Provides: python-s3transfer
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-s3transfer
+
+
+%package help
+Summary: Development documents and examples for s3transfer
+Provides: python3-s3transfer-doc
+%description help
+
+
+%prep
+%autosetup -n s3transfer-0.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-s3transfer -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
+- Package Spec generated