summaryrefslogtreecommitdiff
path: root/python-sanic-jinja2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sanic-jinja2.spec')
-rw-r--r--python-sanic-jinja2.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-sanic-jinja2.spec b/python-sanic-jinja2.spec
new file mode 100644
index 0000000..19d5e3e
--- /dev/null
+++ b/python-sanic-jinja2.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sanic-jinja2
+Version: 2022.11.11
+Release: 1
+Summary: Jinja2 support for sanic
+License: bsd-3-clause
+URL: https://github.com/lixxu/sanic-jinja2
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/18/27/84659caf25557c74a362c8a73361958540ab89c3b0f06860226ab91d6ad5/sanic-jinja2-2022.11.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-sanic
+Requires: python3-jinja2
+
+%description
+Jinja2 support for sanic
+
+%package -n python3-sanic-jinja2
+Summary: Jinja2 support for sanic
+Provides: python-sanic-jinja2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sanic-jinja2
+Jinja2 support for sanic
+
+%package help
+Summary: Development documents and examples for sanic-jinja2
+Provides: python3-sanic-jinja2-doc
+%description help
+Jinja2 support for sanic
+
+%prep
+%autosetup -n sanic-jinja2-2022.11.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sanic-jinja2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2022.11.11-1
+- Package Spec generated