summaryrefslogtreecommitdiff
path: root/python-schwifty.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 21:49:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 21:49:44 +0000
commit3a8f705b0e6a637bbe970085ed7e97304c246d2d (patch)
tree619b71faf4b0f5e08a9d8a927325cd41e6080535 /python-schwifty.spec
parent8ade10a8798550b28d1a26de7ced6d0b8e578112 (diff)
automatic import of python-schwifty
Diffstat (limited to 'python-schwifty.spec')
-rw-r--r--python-schwifty.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-schwifty.spec b/python-schwifty.spec
new file mode 100644
index 0000000..9c96636
--- /dev/null
+++ b/python-schwifty.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-schwifty
+Version: 2023.3.0
+Release: 1
+Summary: Validate/generate IBANs and BICs
+License: MIT
+URL: http://github.com/mdomke/schwifty
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/e9/ec0be527f88d375db7e0415b7ee5465a5ffadf0d9d1ca27867f662c28dfe/schwifty-2023.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-iso3166
+Requires: python3-pycountry
+Requires: python3-importlib-resources
+Requires: python3-importlib-metadata
+
+%description
+``schwifty`` is a Python library that let's you easily work with IBANs and BICs
+as specified by the ISO. IBAN is the Internation Bank Account Number and BIC
+the Business Identifier Code. Both are used for international money transfer.
+
+%package -n python3-schwifty
+Summary: Validate/generate IBANs and BICs
+Provides: python-schwifty
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-schwifty
+``schwifty`` is a Python library that let's you easily work with IBANs and BICs
+as specified by the ISO. IBAN is the Internation Bank Account Number and BIC
+the Business Identifier Code. Both are used for international money transfer.
+
+%package help
+Summary: Development documents and examples for schwifty
+Provides: python3-schwifty-doc
+%description help
+``schwifty`` is a Python library that let's you easily work with IBANs and BICs
+as specified by the ISO. IBAN is the Internation Bank Account Number and BIC
+the Business Identifier Code. Both are used for international money transfer.
+
+%prep
+%autosetup -n schwifty-2023.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-schwifty -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.3.0-1
+- Package Spec generated