summaryrefslogtreecommitdiff
path: root/python-scrapy-eagle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-scrapy-eagle.spec')
-rw-r--r--python-scrapy-eagle.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-scrapy-eagle.spec b/python-scrapy-eagle.spec
new file mode 100644
index 0000000..ce9a2e5
--- /dev/null
+++ b/python-scrapy-eagle.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-scrapy-eagle
+Version: 0.0.37
+Release: 1
+Summary: Run Scrapy Distributed
+License: BSD
+URL: http://github.com/rafaelcapucho/scrapy-eagle
+Source0: https://mirrors.aliyun.com/pypi/web/packages/13/14/861cdbf4a31af11d22f1e61789fafdedfd0f7ade6fef106fe3ce2c38fe73/scrapy-eagle-0.0.37.tar.gz
+BuildArch: noarch
+
+
+%description
+Scrapy Eagle is a tool that allow us to run any Scrapy_ based project in a distributed fashion and monitor how it is going on and how many resources it is consuming on each server.
+**This project is Under Development, don't use it yet**
+
+%package -n python3-scrapy-eagle
+Summary: Run Scrapy Distributed
+Provides: python-scrapy-eagle
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-scrapy-eagle
+Scrapy Eagle is a tool that allow us to run any Scrapy_ based project in a distributed fashion and monitor how it is going on and how many resources it is consuming on each server.
+**This project is Under Development, don't use it yet**
+
+%package help
+Summary: Development documents and examples for scrapy-eagle
+Provides: python3-scrapy-eagle-doc
+%description help
+Scrapy Eagle is a tool that allow us to run any Scrapy_ based project in a distributed fashion and monitor how it is going on and how many resources it is consuming on each server.
+**This project is Under Development, don't use it yet**
+
+%prep
+%autosetup -n scrapy-eagle-0.0.37
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-scrapy-eagle -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.37-1
+- Package Spec generated