summaryrefslogtreecommitdiff
path: root/python-sevenbridges-python.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sevenbridges-python.spec')
-rw-r--r--python-sevenbridges-python.spec167
1 files changed, 167 insertions, 0 deletions
diff --git a/python-sevenbridges-python.spec b/python-sevenbridges-python.spec
new file mode 100644
index 0000000..549d8ef
--- /dev/null
+++ b/python-sevenbridges-python.spec
@@ -0,0 +1,167 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sevenbridges-python
+Version: 2.9.1
+Release: 1
+Summary: SBG API python client bindings
+License: Apache Software License 2.0
+URL: https://github.com/sbg/sevenbridges-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/59/9d/57a2fb1ce178c4fec02d4841dc2693e04f95069ea78a6182f6c019297334/sevenbridges-python-2.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-urllib3
+
+%description
+[![PyPI version](https://badge.fury.io/py/sevenbridges-python.svg)](https://pypi.python.org/pypi/sevenbridges-python)
+[![Documentation](https://readthedocs.org/projects/sevenbridges-python/badge/?version=latest)](http://sevenbridges-python.readthedocs.org/en/latest/)
+[![Licence](https://img.shields.io/badge/licence-Apache-orange.svg)](https://github.com/sbg/sevenbridges-python/blob/develop/LICENCE)
+[CHANGELOG](https://github.com/sbg/sevenbridges-python/releases)
+sevenbridges-python is a [Python](http://www.python.org/) library that
+provides an interface for the [Seven Bridges Platform](https://www.sbgenomics.com/) the
+[Cancer Genomics Cloud](http://www.cancergenomicscloud.org/) and
+[Cavatica](http://www.cavatica.org) public APIs. It works with Python
+versions 3.6+.
+The [Seven Bridges Platform](https://www.sbgenomics.com/) is a
+cloud-based environment for conducting bioinformatic analyses. It is a
+central hub for teams to store, analyze, and jointly interpret their
+bioinformatic data. The Platform co-locates analysis pipelines alongside
+the largest genomic datasets to optimize processing, allocating storage
+and compute resources on demand.
+The [The Cancer Genomics Cloud (CGC)](http://www.cancergenomicscloud.org/), powered by
+[Seven Bridges](https://www.sbgenomics.com/), is also a cloud-based computation
+environment. It was built as one of three pilot systems funded by the
+[National Cancer Institute](http://www.cancer.gov/) to explore the
+paradigm of colocalizing massive genomics datasets, like The
+[Cancer Genomics Atlas (TCGA)](http://cancergenome.nih.gov/), alongside secure
+and scalable computational resources to analyze them. The CGC makes more
+than a petabyte of multi-dimensional data available immediately to
+authorized researchers. You can add your own data to analyze alongside
+TCGA using predefined analytical workflows or your own tools.
+The [Cavatica](http://www.cavatica.org/),
+powered by [Seven Bridges](https://www.sbgenomics.com/), is a data analysis and sharing
+platform designed to accelerate discovery in a scalable, cloud-based
+compute environment where data, results, and workflows are shared among
+the world's research community. Cavatica is built in collaboration with
+the Children Hospital of Philadelphia and it is focused on pediatric
+data.
+
+%package -n python3-sevenbridges-python
+Summary: SBG API python client bindings
+Provides: python-sevenbridges-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sevenbridges-python
+[![PyPI version](https://badge.fury.io/py/sevenbridges-python.svg)](https://pypi.python.org/pypi/sevenbridges-python)
+[![Documentation](https://readthedocs.org/projects/sevenbridges-python/badge/?version=latest)](http://sevenbridges-python.readthedocs.org/en/latest/)
+[![Licence](https://img.shields.io/badge/licence-Apache-orange.svg)](https://github.com/sbg/sevenbridges-python/blob/develop/LICENCE)
+[CHANGELOG](https://github.com/sbg/sevenbridges-python/releases)
+sevenbridges-python is a [Python](http://www.python.org/) library that
+provides an interface for the [Seven Bridges Platform](https://www.sbgenomics.com/) the
+[Cancer Genomics Cloud](http://www.cancergenomicscloud.org/) and
+[Cavatica](http://www.cavatica.org) public APIs. It works with Python
+versions 3.6+.
+The [Seven Bridges Platform](https://www.sbgenomics.com/) is a
+cloud-based environment for conducting bioinformatic analyses. It is a
+central hub for teams to store, analyze, and jointly interpret their
+bioinformatic data. The Platform co-locates analysis pipelines alongside
+the largest genomic datasets to optimize processing, allocating storage
+and compute resources on demand.
+The [The Cancer Genomics Cloud (CGC)](http://www.cancergenomicscloud.org/), powered by
+[Seven Bridges](https://www.sbgenomics.com/), is also a cloud-based computation
+environment. It was built as one of three pilot systems funded by the
+[National Cancer Institute](http://www.cancer.gov/) to explore the
+paradigm of colocalizing massive genomics datasets, like The
+[Cancer Genomics Atlas (TCGA)](http://cancergenome.nih.gov/), alongside secure
+and scalable computational resources to analyze them. The CGC makes more
+than a petabyte of multi-dimensional data available immediately to
+authorized researchers. You can add your own data to analyze alongside
+TCGA using predefined analytical workflows or your own tools.
+The [Cavatica](http://www.cavatica.org/),
+powered by [Seven Bridges](https://www.sbgenomics.com/), is a data analysis and sharing
+platform designed to accelerate discovery in a scalable, cloud-based
+compute environment where data, results, and workflows are shared among
+the world's research community. Cavatica is built in collaboration with
+the Children Hospital of Philadelphia and it is focused on pediatric
+data.
+
+%package help
+Summary: Development documents and examples for sevenbridges-python
+Provides: python3-sevenbridges-python-doc
+%description help
+[![PyPI version](https://badge.fury.io/py/sevenbridges-python.svg)](https://pypi.python.org/pypi/sevenbridges-python)
+[![Documentation](https://readthedocs.org/projects/sevenbridges-python/badge/?version=latest)](http://sevenbridges-python.readthedocs.org/en/latest/)
+[![Licence](https://img.shields.io/badge/licence-Apache-orange.svg)](https://github.com/sbg/sevenbridges-python/blob/develop/LICENCE)
+[CHANGELOG](https://github.com/sbg/sevenbridges-python/releases)
+sevenbridges-python is a [Python](http://www.python.org/) library that
+provides an interface for the [Seven Bridges Platform](https://www.sbgenomics.com/) the
+[Cancer Genomics Cloud](http://www.cancergenomicscloud.org/) and
+[Cavatica](http://www.cavatica.org) public APIs. It works with Python
+versions 3.6+.
+The [Seven Bridges Platform](https://www.sbgenomics.com/) is a
+cloud-based environment for conducting bioinformatic analyses. It is a
+central hub for teams to store, analyze, and jointly interpret their
+bioinformatic data. The Platform co-locates analysis pipelines alongside
+the largest genomic datasets to optimize processing, allocating storage
+and compute resources on demand.
+The [The Cancer Genomics Cloud (CGC)](http://www.cancergenomicscloud.org/), powered by
+[Seven Bridges](https://www.sbgenomics.com/), is also a cloud-based computation
+environment. It was built as one of three pilot systems funded by the
+[National Cancer Institute](http://www.cancer.gov/) to explore the
+paradigm of colocalizing massive genomics datasets, like The
+[Cancer Genomics Atlas (TCGA)](http://cancergenome.nih.gov/), alongside secure
+and scalable computational resources to analyze them. The CGC makes more
+than a petabyte of multi-dimensional data available immediately to
+authorized researchers. You can add your own data to analyze alongside
+TCGA using predefined analytical workflows or your own tools.
+The [Cavatica](http://www.cavatica.org/),
+powered by [Seven Bridges](https://www.sbgenomics.com/), is a data analysis and sharing
+platform designed to accelerate discovery in a scalable, cloud-based
+compute environment where data, results, and workflows are shared among
+the world's research community. Cavatica is built in collaboration with
+the Children Hospital of Philadelphia and it is focused on pediatric
+data.
+
+%prep
+%autosetup -n sevenbridges-python-2.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sevenbridges-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.9.1-1
+- Package Spec generated