summaryrefslogtreecommitdiff
path: root/python-sewer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sewer.spec')
-rw-r--r--python-sewer.spec418
1 files changed, 418 insertions, 0 deletions
diff --git a/python-sewer.spec b/python-sewer.spec
new file mode 100644
index 0000000..298c5e6
--- /dev/null
+++ b/python-sewer.spec
@@ -0,0 +1,418 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sewer
+Version: 0.8.4
+Release: 1
+Summary: Sewer is a programmatic Lets Encrypt(ACME) client
+License: MIT
+URL: https://github.com/komuw/sewer
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/35/69/1993952131260af82d2cfc62f14c824838840e68f1b1aee29dba4d8bfec5/sewer-0.8.4.tar.gz
+BuildArch: noarch
+
+Requires: python3-cryptography
+Requires: python3-requests
+Requires: python3-dnspython
+Requires: python3-aliyun-python-sdk-alidns
+Requires: python3-aliyun-python-sdk-core-v3
+Requires: python3-aliyun-python-sdk-alidns
+Requires: python3-aliyun-python-sdk-core-v3
+Requires: python3-apache-libcloud
+Requires: python3-boto3
+Requires: python3-cloudns-api
+Requires: python3-dnspython
+Requires: python3-hurricanedns
+Requires: python3-tldextract
+Requires: python3-apache-libcloud
+Requires: python3-tldextract
+Requires: python3-cloudns-api
+Requires: python3-twine
+Requires: python3-wheel
+Requires: python3-hurricanedns
+Requires: python3-tldextract
+Requires: python3-boto3
+Requires: python3-black
+Requires: python3-coverage
+Requires: python3-pylint
+Requires: python3-pytest
+
+%description
+## Sewer
+
+[![Codacy Badge](https://api.codacy.com/project/badge/Grade/ccf655afb3974e9698025cbb65949aa2)](https://www.codacy.com/app/komuW/sewer?utm_source=github.com&utm_medium=referral&utm_content=komuW/sewer&utm_campaign=Badge_Grade)
+[![CircleCI](https://circleci.com/gh/komuw/sewer.svg?style=svg)](https://circleci.com/gh/komuw/sewer)
+[![codecov](https://codecov.io/gh/komuW/sewer/branch/master/graph/badge.svg)](https://codecov.io/gh/komuW/sewer)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/komuw/sewer)
+
+Sewer is a Let's Encrypt(ACME) client.
+It's name is derived from Kenyan hip hop artiste, Kitu Sewer.
+
+- The stable release is [0.8.4](https://komuw.github.io/sewer/notes/0.8.4-notes).
+- More history in the [CHANGELOG](https://komuw.github.io/sewer/CHANGELOG).
+
+PYTHON compatibility: 3.5 is nominally still supported, and with assistance
+from Github's multi-version Python linting I've repaired some issues. Even
+with the GH multi-version testing, there are parts of the drivers,
+especially, which I simply can't test (with 3.5) because the actual service
+provider interaction has to be mocked. Such issues will be fixed on a
+best-effort basis when reported for the life of 0.8.
+
+I (maintainer @mmaney) loiter in channel ##sewer (on irc.freenode.net) for
+those who remember IRC. Don't ask to ask, but waiting is.
+
+## Features
+- Obtain or renew SSL/TLS certificates from [Let's Encrypt](https://letsencrypt.org)
+- Supports acme version 2 (current RFC including post-as-get).
+- Support for SAN certificates.
+- Supports [wildcard certificates](https://komuw.github.io/sewer/wildcards).
+- Bundling certificates.
+- Support for both RSA and ECDSA for account and certificate keys.
+- Supports [DNS and HTTP](https://komuw.github.io/sewer/UnifiedProvider) challenges
+ - List of currently supported
+ [DNS services and BYO-service notes](https://komuw.github.io/sewer/dns-01)
+ - HTTP challenges are a new feature, no operational drivers in the tree
+ yet. [See usage and BYO-service notes](https://komuw.github.io/sewer/http-01)
+- sewer is both a [command-line program](https://komuw.github.io/sewer/sewer-cli)
+ and a [Python library](https://komuw.github.io/sewer/sewer-as-a-library) for custom use
+- Well written(if I have to say so myself):
+ - [Good test coverage](https://codecov.io/gh/komuW/sewer)
+ - [Passing continuous integration](https://circleci.com/gh/komuW/sewer)
+ - [High grade statically analyzed code](https://www.codacy.com/app/komuW/sewer/dashboard)
+ - type hinting to support mypy verification is a recently begun WIP
+
+## Installation
+
+```shell
+pip3 install sewer
+
+# with All DNS Provider support, include aliyun, Hurricane Electric, Aurora, ACME ...
+# pip3 install sewer[alldns]
+
+# with Cloudflare support
+# pip3 install sewer[cloudflare]
+
+# with Aliyun support
+# pip3 install sewer[aliyun]
+
+# with HE DNS(Hurricane Electric DNS) support
+# pip3 install sewer[hurricane]
+
+# with Aurora DNS Support
+# pip3 install sewer[aurora]
+
+# with ACME DNS Support
+# pip3 install sewer[acmedns]
+
+# with Rackspace DNS Support
+# pip3 install sewer[rackspace]
+
+# with DNSPod DNS Support
+# pip3 install sewer[dnspod]
+
+# with DuckDNS DNS Support
+# pip3 install sewer[duckdns]
+
+# with ClouDNS DNS Support
+# pip3 install sewer[cloudns]
+
+# with AWS Route 53 DNS Support
+# pip3 install sewer[route53]
+
+# with PowerDNS DNS Support
+# pip3 install sewer[powerdns]
+```
+
+sewer(since version 0.5.0) is now python3 only. To install the (now
+unsupported) python2 version:
+
+```shell
+pip install sewer==0.3.0
+```
+
+Sewer is in active development and it's API will change in backward incompatible ways.
+[https://pypi.python.org/pypi/sewer](https://pypi.python.org/pypi/sewer)
+
+## Development setup
+
+See the how to contribute [documentation](https://github.com/komuw/sewer/blob/master/.github/CONTRIBUTING.md)
+
+## FAQ
+- Why another ACME client?
+ I wanted an ACME client that I could use to programmatically(as a library) acquire/get certificates. However I could not
+ find anything satisfactory for use in Python code.
+- Why is it called Sewer?
+ I really like the Kenyan hip hop artiste going by the name of Kitu Sewer.
+
+
+
+
+%package -n python3-sewer
+Summary: Sewer is a programmatic Lets Encrypt(ACME) client
+Provides: python-sewer
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sewer
+## Sewer
+
+[![Codacy Badge](https://api.codacy.com/project/badge/Grade/ccf655afb3974e9698025cbb65949aa2)](https://www.codacy.com/app/komuW/sewer?utm_source=github.com&utm_medium=referral&utm_content=komuW/sewer&utm_campaign=Badge_Grade)
+[![CircleCI](https://circleci.com/gh/komuw/sewer.svg?style=svg)](https://circleci.com/gh/komuw/sewer)
+[![codecov](https://codecov.io/gh/komuW/sewer/branch/master/graph/badge.svg)](https://codecov.io/gh/komuW/sewer)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/komuw/sewer)
+
+Sewer is a Let's Encrypt(ACME) client.
+It's name is derived from Kenyan hip hop artiste, Kitu Sewer.
+
+- The stable release is [0.8.4](https://komuw.github.io/sewer/notes/0.8.4-notes).
+- More history in the [CHANGELOG](https://komuw.github.io/sewer/CHANGELOG).
+
+PYTHON compatibility: 3.5 is nominally still supported, and with assistance
+from Github's multi-version Python linting I've repaired some issues. Even
+with the GH multi-version testing, there are parts of the drivers,
+especially, which I simply can't test (with 3.5) because the actual service
+provider interaction has to be mocked. Such issues will be fixed on a
+best-effort basis when reported for the life of 0.8.
+
+I (maintainer @mmaney) loiter in channel ##sewer (on irc.freenode.net) for
+those who remember IRC. Don't ask to ask, but waiting is.
+
+## Features
+- Obtain or renew SSL/TLS certificates from [Let's Encrypt](https://letsencrypt.org)
+- Supports acme version 2 (current RFC including post-as-get).
+- Support for SAN certificates.
+- Supports [wildcard certificates](https://komuw.github.io/sewer/wildcards).
+- Bundling certificates.
+- Support for both RSA and ECDSA for account and certificate keys.
+- Supports [DNS and HTTP](https://komuw.github.io/sewer/UnifiedProvider) challenges
+ - List of currently supported
+ [DNS services and BYO-service notes](https://komuw.github.io/sewer/dns-01)
+ - HTTP challenges are a new feature, no operational drivers in the tree
+ yet. [See usage and BYO-service notes](https://komuw.github.io/sewer/http-01)
+- sewer is both a [command-line program](https://komuw.github.io/sewer/sewer-cli)
+ and a [Python library](https://komuw.github.io/sewer/sewer-as-a-library) for custom use
+- Well written(if I have to say so myself):
+ - [Good test coverage](https://codecov.io/gh/komuW/sewer)
+ - [Passing continuous integration](https://circleci.com/gh/komuW/sewer)
+ - [High grade statically analyzed code](https://www.codacy.com/app/komuW/sewer/dashboard)
+ - type hinting to support mypy verification is a recently begun WIP
+
+## Installation
+
+```shell
+pip3 install sewer
+
+# with All DNS Provider support, include aliyun, Hurricane Electric, Aurora, ACME ...
+# pip3 install sewer[alldns]
+
+# with Cloudflare support
+# pip3 install sewer[cloudflare]
+
+# with Aliyun support
+# pip3 install sewer[aliyun]
+
+# with HE DNS(Hurricane Electric DNS) support
+# pip3 install sewer[hurricane]
+
+# with Aurora DNS Support
+# pip3 install sewer[aurora]
+
+# with ACME DNS Support
+# pip3 install sewer[acmedns]
+
+# with Rackspace DNS Support
+# pip3 install sewer[rackspace]
+
+# with DNSPod DNS Support
+# pip3 install sewer[dnspod]
+
+# with DuckDNS DNS Support
+# pip3 install sewer[duckdns]
+
+# with ClouDNS DNS Support
+# pip3 install sewer[cloudns]
+
+# with AWS Route 53 DNS Support
+# pip3 install sewer[route53]
+
+# with PowerDNS DNS Support
+# pip3 install sewer[powerdns]
+```
+
+sewer(since version 0.5.0) is now python3 only. To install the (now
+unsupported) python2 version:
+
+```shell
+pip install sewer==0.3.0
+```
+
+Sewer is in active development and it's API will change in backward incompatible ways.
+[https://pypi.python.org/pypi/sewer](https://pypi.python.org/pypi/sewer)
+
+## Development setup
+
+See the how to contribute [documentation](https://github.com/komuw/sewer/blob/master/.github/CONTRIBUTING.md)
+
+## FAQ
+- Why another ACME client?
+ I wanted an ACME client that I could use to programmatically(as a library) acquire/get certificates. However I could not
+ find anything satisfactory for use in Python code.
+- Why is it called Sewer?
+ I really like the Kenyan hip hop artiste going by the name of Kitu Sewer.
+
+
+
+
+%package help
+Summary: Development documents and examples for sewer
+Provides: python3-sewer-doc
+%description help
+## Sewer
+
+[![Codacy Badge](https://api.codacy.com/project/badge/Grade/ccf655afb3974e9698025cbb65949aa2)](https://www.codacy.com/app/komuW/sewer?utm_source=github.com&utm_medium=referral&utm_content=komuW/sewer&utm_campaign=Badge_Grade)
+[![CircleCI](https://circleci.com/gh/komuw/sewer.svg?style=svg)](https://circleci.com/gh/komuw/sewer)
+[![codecov](https://codecov.io/gh/komuW/sewer/branch/master/graph/badge.svg)](https://codecov.io/gh/komuW/sewer)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/komuw/sewer)
+
+Sewer is a Let's Encrypt(ACME) client.
+It's name is derived from Kenyan hip hop artiste, Kitu Sewer.
+
+- The stable release is [0.8.4](https://komuw.github.io/sewer/notes/0.8.4-notes).
+- More history in the [CHANGELOG](https://komuw.github.io/sewer/CHANGELOG).
+
+PYTHON compatibility: 3.5 is nominally still supported, and with assistance
+from Github's multi-version Python linting I've repaired some issues. Even
+with the GH multi-version testing, there are parts of the drivers,
+especially, which I simply can't test (with 3.5) because the actual service
+provider interaction has to be mocked. Such issues will be fixed on a
+best-effort basis when reported for the life of 0.8.
+
+I (maintainer @mmaney) loiter in channel ##sewer (on irc.freenode.net) for
+those who remember IRC. Don't ask to ask, but waiting is.
+
+## Features
+- Obtain or renew SSL/TLS certificates from [Let's Encrypt](https://letsencrypt.org)
+- Supports acme version 2 (current RFC including post-as-get).
+- Support for SAN certificates.
+- Supports [wildcard certificates](https://komuw.github.io/sewer/wildcards).
+- Bundling certificates.
+- Support for both RSA and ECDSA for account and certificate keys.
+- Supports [DNS and HTTP](https://komuw.github.io/sewer/UnifiedProvider) challenges
+ - List of currently supported
+ [DNS services and BYO-service notes](https://komuw.github.io/sewer/dns-01)
+ - HTTP challenges are a new feature, no operational drivers in the tree
+ yet. [See usage and BYO-service notes](https://komuw.github.io/sewer/http-01)
+- sewer is both a [command-line program](https://komuw.github.io/sewer/sewer-cli)
+ and a [Python library](https://komuw.github.io/sewer/sewer-as-a-library) for custom use
+- Well written(if I have to say so myself):
+ - [Good test coverage](https://codecov.io/gh/komuW/sewer)
+ - [Passing continuous integration](https://circleci.com/gh/komuW/sewer)
+ - [High grade statically analyzed code](https://www.codacy.com/app/komuW/sewer/dashboard)
+ - type hinting to support mypy verification is a recently begun WIP
+
+## Installation
+
+```shell
+pip3 install sewer
+
+# with All DNS Provider support, include aliyun, Hurricane Electric, Aurora, ACME ...
+# pip3 install sewer[alldns]
+
+# with Cloudflare support
+# pip3 install sewer[cloudflare]
+
+# with Aliyun support
+# pip3 install sewer[aliyun]
+
+# with HE DNS(Hurricane Electric DNS) support
+# pip3 install sewer[hurricane]
+
+# with Aurora DNS Support
+# pip3 install sewer[aurora]
+
+# with ACME DNS Support
+# pip3 install sewer[acmedns]
+
+# with Rackspace DNS Support
+# pip3 install sewer[rackspace]
+
+# with DNSPod DNS Support
+# pip3 install sewer[dnspod]
+
+# with DuckDNS DNS Support
+# pip3 install sewer[duckdns]
+
+# with ClouDNS DNS Support
+# pip3 install sewer[cloudns]
+
+# with AWS Route 53 DNS Support
+# pip3 install sewer[route53]
+
+# with PowerDNS DNS Support
+# pip3 install sewer[powerdns]
+```
+
+sewer(since version 0.5.0) is now python3 only. To install the (now
+unsupported) python2 version:
+
+```shell
+pip install sewer==0.3.0
+```
+
+Sewer is in active development and it's API will change in backward incompatible ways.
+[https://pypi.python.org/pypi/sewer](https://pypi.python.org/pypi/sewer)
+
+## Development setup
+
+See the how to contribute [documentation](https://github.com/komuw/sewer/blob/master/.github/CONTRIBUTING.md)
+
+## FAQ
+- Why another ACME client?
+ I wanted an ACME client that I could use to programmatically(as a library) acquire/get certificates. However I could not
+ find anything satisfactory for use in Python code.
+- Why is it called Sewer?
+ I really like the Kenyan hip hop artiste going by the name of Kitu Sewer.
+
+
+
+
+%prep
+%autosetup -n sewer-0.8.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sewer -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.4-1
+- Package Spec generated