summaryrefslogtreecommitdiff
path: root/python-shutit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-shutit.spec')
-rw-r--r--python-shutit.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-shutit.spec b/python-shutit.spec
new file mode 100644
index 0000000..f2cc6f0
--- /dev/null
+++ b/python-shutit.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-shutit
+Version: 1.0.173
+Release: 1
+Summary: A programmable automation tool designed for complex builds
+License: MIT
+URL: http://ianmiell.github.io/shutit/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/24/65d389ed9cde6f846535026852dc36aad994c12fa5e2563cb6ab6fb53933/shutit-1.0.173.tar.gz
+BuildArch: noarch
+
+
+%description
+A programmable shell-based (pexpect) automation tool designed for complex builds. See: http://ianmiell.github.io/shutit
+
+%package -n python3-shutit
+Summary: A programmable automation tool designed for complex builds
+Provides: python-shutit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-shutit
+A programmable shell-based (pexpect) automation tool designed for complex builds. See: http://ianmiell.github.io/shutit
+
+%package help
+Summary: Development documents and examples for shutit
+Provides: python3-shutit-doc
+%description help
+A programmable shell-based (pexpect) automation tool designed for complex builds. See: http://ianmiell.github.io/shutit
+
+%prep
+%autosetup -n shutit-1.0.173
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-shutit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.173-1
+- Package Spec generated