summaryrefslogtreecommitdiff
path: root/python-simplecalculator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-simplecalculator.spec')
-rw-r--r--python-simplecalculator.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-simplecalculator.spec b/python-simplecalculator.spec
new file mode 100644
index 0000000..ea95230
--- /dev/null
+++ b/python-simplecalculator.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-simplecalculator
+Version: 0.0.4
+Release: 1
+Summary: A simple calculator library.
+License: UNKNOWN
+URL: https://github.com/badmetacoder/calculator
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/69/d8/3e50699faedb93a5818c962faefe81afdbbc2aa4a9ad55e6098f5416ece2/simplecalculator-0.0.4.tar.gz
+BuildArch: noarch
+
+
+%description
+A simple calculator library.
+This module is now a Python package. You can install it using:
+ $ sudo pip install simplecalculator
+Examples of usage:
+ * `simplecalculator.py` -- a command-line utility
+ * `tornadoweb.py` -- a TornadoWeb applications with a minimalistic RESTful API. Do you math with curl!
+
+%package -n python3-simplecalculator
+Summary: A simple calculator library.
+Provides: python-simplecalculator
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-simplecalculator
+A simple calculator library.
+This module is now a Python package. You can install it using:
+ $ sudo pip install simplecalculator
+Examples of usage:
+ * `simplecalculator.py` -- a command-line utility
+ * `tornadoweb.py` -- a TornadoWeb applications with a minimalistic RESTful API. Do you math with curl!
+
+%package help
+Summary: Development documents and examples for simplecalculator
+Provides: python3-simplecalculator-doc
+%description help
+A simple calculator library.
+This module is now a Python package. You can install it using:
+ $ sudo pip install simplecalculator
+Examples of usage:
+ * `simplecalculator.py` -- a command-line utility
+ * `tornadoweb.py` -- a TornadoWeb applications with a minimalistic RESTful API. Do you math with curl!
+
+%prep
+%autosetup -n simplecalculator-0.0.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-simplecalculator -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.4-1
+- Package Spec generated