summaryrefslogtreecommitdiff
path: root/python-smartystreets-python-sdk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-smartystreets-python-sdk.spec')
-rw-r--r--python-smartystreets-python-sdk.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-smartystreets-python-sdk.spec b/python-smartystreets-python-sdk.spec
new file mode 100644
index 0000000..b8fc29c
--- /dev/null
+++ b/python-smartystreets-python-sdk.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-smartystreets-python-sdk
+Version: 4.11.16
+Release: 1
+Summary: An official library to help Python developers easily access the SmartyStreets APIs
+License: Apache 2
+URL: https://github.com/smartystreets/smartystreets-python-sdk
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c2/f0/fcf8c0976235e441417b045ffb6a760a0fabe801179893d1e787406f4fb1/smartystreets_python_sdk-4.11.16.tar.gz
+BuildArch: noarch
+
+
+%description
+Official Python library for SmartyStreets
+
+
+%package -n python3-smartystreets-python-sdk
+Summary: An official library to help Python developers easily access the SmartyStreets APIs
+Provides: python-smartystreets-python-sdk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-smartystreets-python-sdk
+Official Python library for SmartyStreets
+
+
+%package help
+Summary: Development documents and examples for smartystreets-python-sdk
+Provides: python3-smartystreets-python-sdk-doc
+%description help
+Official Python library for SmartyStreets
+
+
+%prep
+%autosetup -n smartystreets-python-sdk-4.11.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-smartystreets-python-sdk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 4.11.16-1
+- Package Spec generated