summaryrefslogtreecommitdiff
path: root/python-smsutil.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-smsutil.spec')
-rw-r--r--python-smsutil.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-smsutil.spec b/python-smsutil.spec
new file mode 100644
index 0000000..255046d
--- /dev/null
+++ b/python-smsutil.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-smsutil
+Version: 1.1.3
+Release: 1
+Summary: encode, decode and split SMS.
+License: MIT
+URL: https://github.com/jezeniel/smsutil
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/83/ae/b5ebcfc33dfbb6d09d5072341c7629fdce9588e080615924c2a465923aa2/smsutil-1.1.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-future
+
+%description
+Simple set of utility functions for encoding, decoding and splitting
+sms messages. Shift tables is currently not supported.
+
+%package -n python3-smsutil
+Summary: encode, decode and split SMS.
+Provides: python-smsutil
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-smsutil
+Simple set of utility functions for encoding, decoding and splitting
+sms messages. Shift tables is currently not supported.
+
+%package help
+Summary: Development documents and examples for smsutil
+Provides: python3-smsutil-doc
+%description help
+Simple set of utility functions for encoding, decoding and splitting
+sms messages. Shift tables is currently not supported.
+
+%prep
+%autosetup -n smsutil-1.1.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-smsutil -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.3-1
+- Package Spec generated