summaryrefslogtreecommitdiff
path: root/python-snaql.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 07:11:35 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 07:11:35 +0000
commitdb6fea13348f9485b9ef5c2bdde32a3bb6f26a46 (patch)
tree157c8f6667278d36daa285cb3bc434048a55aad2 /python-snaql.spec
parentf2c8f0a8e0b2e77cac0bdd2ca64c9f0c32c360ca (diff)
automatic import of python-snaql
Diffstat (limited to 'python-snaql.spec')
-rw-r--r--python-snaql.spec182
1 files changed, 182 insertions, 0 deletions
diff --git a/python-snaql.spec b/python-snaql.spec
new file mode 100644
index 0000000..867f52e
--- /dev/null
+++ b/python-snaql.spec
@@ -0,0 +1,182 @@
+%global _empty_manifest_terminate_build 0
+Name: python-snaql
+Version: 0.4.2
+Release: 1
+Summary: Transparant *QL usage without ORM
+License: MIT
+URL: https://github.com/semirook/snaql
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cd/fd/614fdb2246adc2f31d4c11810670e30332f34216ca5f5904914e862b9551/snaql-0.4.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-Jinja2
+Requires: python3-schema
+
+%description
+
+# Snaql. Raw \*QL queries in Python without pain [![Build Status](https://travis-ci.org/semirook/snaql.png)](https://travis-ci.org/semirook/snaql)
+
+Totally inspired by [Yesql](https://github.com/krisajenkins/yesql) from Clojure world.
+But implemented in another way.
+
+## What?
+
+I totally agree with Yesql's author that SQL is already a mature DSL and great abstaction layer
+for DB queries building. And we don't need another layer above SQL to work with RDBMS like ORMs
+or complicated DSLs. Feel free to use all of the SQL's power in your projects without mixing Python
+code and SQL strings. Solution is very simple and flexible enough to try it in your next project.
+Also, Snaql doesn't depend on DB clients, can be used in asynchronous handlers (Tornado, for example).
+It's just a way to organize your queries and a bit of logic to change them by context. Look at examples.
+
+Actually, Snaql doesn't care about stuff you want to build. SQL, SPARQL, SphinxQL, CQL etc.,
+you can build any query for any DB or search engine. Freedom.
+
+## Installation
+
+As usual, with pip:
+
+```bash
+$ pip install snaql
+```
+
+## Documentation
+
+You always can find the most recent docs with examples on [Snaql GitBook](https://semirook.gitbooks.io/snaql/content/)
+
+
+Simple, without DB clients dependencies (use what you need). Try!
+
+Tested in Python 2.7, 3.3, 3.4, 3.5
+
+
+
+
+%package -n python3-snaql
+Summary: Transparant *QL usage without ORM
+Provides: python-snaql
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-snaql
+
+# Snaql. Raw \*QL queries in Python without pain [![Build Status](https://travis-ci.org/semirook/snaql.png)](https://travis-ci.org/semirook/snaql)
+
+Totally inspired by [Yesql](https://github.com/krisajenkins/yesql) from Clojure world.
+But implemented in another way.
+
+## What?
+
+I totally agree with Yesql's author that SQL is already a mature DSL and great abstaction layer
+for DB queries building. And we don't need another layer above SQL to work with RDBMS like ORMs
+or complicated DSLs. Feel free to use all of the SQL's power in your projects without mixing Python
+code and SQL strings. Solution is very simple and flexible enough to try it in your next project.
+Also, Snaql doesn't depend on DB clients, can be used in asynchronous handlers (Tornado, for example).
+It's just a way to organize your queries and a bit of logic to change them by context. Look at examples.
+
+Actually, Snaql doesn't care about stuff you want to build. SQL, SPARQL, SphinxQL, CQL etc.,
+you can build any query for any DB or search engine. Freedom.
+
+## Installation
+
+As usual, with pip:
+
+```bash
+$ pip install snaql
+```
+
+## Documentation
+
+You always can find the most recent docs with examples on [Snaql GitBook](https://semirook.gitbooks.io/snaql/content/)
+
+
+Simple, without DB clients dependencies (use what you need). Try!
+
+Tested in Python 2.7, 3.3, 3.4, 3.5
+
+
+
+
+%package help
+Summary: Development documents and examples for snaql
+Provides: python3-snaql-doc
+%description help
+
+# Snaql. Raw \*QL queries in Python without pain [![Build Status](https://travis-ci.org/semirook/snaql.png)](https://travis-ci.org/semirook/snaql)
+
+Totally inspired by [Yesql](https://github.com/krisajenkins/yesql) from Clojure world.
+But implemented in another way.
+
+## What?
+
+I totally agree with Yesql's author that SQL is already a mature DSL and great abstaction layer
+for DB queries building. And we don't need another layer above SQL to work with RDBMS like ORMs
+or complicated DSLs. Feel free to use all of the SQL's power in your projects without mixing Python
+code and SQL strings. Solution is very simple and flexible enough to try it in your next project.
+Also, Snaql doesn't depend on DB clients, can be used in asynchronous handlers (Tornado, for example).
+It's just a way to organize your queries and a bit of logic to change them by context. Look at examples.
+
+Actually, Snaql doesn't care about stuff you want to build. SQL, SPARQL, SphinxQL, CQL etc.,
+you can build any query for any DB or search engine. Freedom.
+
+## Installation
+
+As usual, with pip:
+
+```bash
+$ pip install snaql
+```
+
+## Documentation
+
+You always can find the most recent docs with examples on [Snaql GitBook](https://semirook.gitbooks.io/snaql/content/)
+
+
+Simple, without DB clients dependencies (use what you need). Try!
+
+Tested in Python 2.7, 3.3, 3.4, 3.5
+
+
+
+
+%prep
+%autosetup -n snaql-0.4.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-snaql -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.2-1
+- Package Spec generated