summaryrefslogtreecommitdiff
path: root/python-sorl-thumbnail.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-sorl-thumbnail.spec')
-rw-r--r--python-sorl-thumbnail.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-sorl-thumbnail.spec b/python-sorl-thumbnail.spec
new file mode 100644
index 0000000..077b6f4
--- /dev/null
+++ b/python-sorl-thumbnail.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sorl-thumbnail
+Version: 12.9.0
+Release: 1
+Summary: Thumbnails for Django
+License: BSD
+URL: https://github.com/jazzband/sorl-thumbnail
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0a/bc/cf201540a1be4a9e086d58bfd90f87225f32725de1df38e424475f8d3060/sorl-thumbnail-12.9.0.tar.gz
+BuildArch: noarch
+
+
+%description
+- Support for Django 3.2, 4.0 and 4.1 following the `Django supported versions policy`_
+- Python 3 support
+- Storage support
+- Pluggable Engine support for `Pillow`_, `ImageMagick`_, `PIL`_, `Wand`_, `pgmagick`_, and `vipsthumbnail`_
+- Pluggable Key Value Store support (cached db, redis, and dynamodb by AWS)
+- Pluggable Backend support
+- Admin integration with possibility to delete
+- Dummy generation (placeholders)
+- Flexible, simple syntax, generates no html
+- ImageField for model that deletes thumbnails (only compatible with django 1.2.5 or less)
+- CSS style cropping options
+- Back smart cropping, and remove borders from the images when cropping
+- Margin calculation for vertical positioning
+- Alternative resolutions versions of a thumbnail
+Read more in `the documentation (latest version) <https://sorl-thumbnail.readthedocs.io/>`_
+
+%package -n python3-sorl-thumbnail
+Summary: Thumbnails for Django
+Provides: python-sorl-thumbnail
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sorl-thumbnail
+- Support for Django 3.2, 4.0 and 4.1 following the `Django supported versions policy`_
+- Python 3 support
+- Storage support
+- Pluggable Engine support for `Pillow`_, `ImageMagick`_, `PIL`_, `Wand`_, `pgmagick`_, and `vipsthumbnail`_
+- Pluggable Key Value Store support (cached db, redis, and dynamodb by AWS)
+- Pluggable Backend support
+- Admin integration with possibility to delete
+- Dummy generation (placeholders)
+- Flexible, simple syntax, generates no html
+- ImageField for model that deletes thumbnails (only compatible with django 1.2.5 or less)
+- CSS style cropping options
+- Back smart cropping, and remove borders from the images when cropping
+- Margin calculation for vertical positioning
+- Alternative resolutions versions of a thumbnail
+Read more in `the documentation (latest version) <https://sorl-thumbnail.readthedocs.io/>`_
+
+%package help
+Summary: Development documents and examples for sorl-thumbnail
+Provides: python3-sorl-thumbnail-doc
+%description help
+- Support for Django 3.2, 4.0 and 4.1 following the `Django supported versions policy`_
+- Python 3 support
+- Storage support
+- Pluggable Engine support for `Pillow`_, `ImageMagick`_, `PIL`_, `Wand`_, `pgmagick`_, and `vipsthumbnail`_
+- Pluggable Key Value Store support (cached db, redis, and dynamodb by AWS)
+- Pluggable Backend support
+- Admin integration with possibility to delete
+- Dummy generation (placeholders)
+- Flexible, simple syntax, generates no html
+- ImageField for model that deletes thumbnails (only compatible with django 1.2.5 or less)
+- CSS style cropping options
+- Back smart cropping, and remove borders from the images when cropping
+- Margin calculation for vertical positioning
+- Alternative resolutions versions of a thumbnail
+Read more in `the documentation (latest version) <https://sorl-thumbnail.readthedocs.io/>`_
+
+%prep
+%autosetup -n sorl-thumbnail-12.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sorl-thumbnail -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 12.9.0-1
+- Package Spec generated