summaryrefslogtreecommitdiff
path: root/python-sphinxcontrib-kana-text.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 03:19:24 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 03:19:24 +0000
commit69c421399012f4c6684e8e1e27f2424f91170516 (patch)
tree3c27339c666df9a4b2a0d96860162fd279c3bd9b /python-sphinxcontrib-kana-text.spec
parent9583948da360223dc64a75999ae0c44b0a1958c2 (diff)
automatic import of python-sphinxcontrib-kana-text
Diffstat (limited to 'python-sphinxcontrib-kana-text.spec')
-rw-r--r--python-sphinxcontrib-kana-text.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-sphinxcontrib-kana-text.spec b/python-sphinxcontrib-kana-text.spec
new file mode 100644
index 0000000..9137cde
--- /dev/null
+++ b/python-sphinxcontrib-kana-text.spec
@@ -0,0 +1,120 @@
+%global _empty_manifest_terminate_build 0
+Name: python-sphinxcontrib.kana-text
+Version: 0.32.1
+Release: 1
+Summary: KanaText class extends the functionality of Text class, for someone who use index/glossary directives.
+License: BSD 2-Clause License
+URL: https://qiita.com/tags/sphinxcotrib.kana_text
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/74/e1/86b8fad52625d807c57b8543b495c8eafebe41a101d683619598e1b1ef00/sphinxcontrib.kana_text-0.32.1.tar.gz
+BuildArch: noarch
+
+
+%description
+installtion
+ $ pip install sphindexer sphinxcontrib.kana_text
+conf.py:
+ extensions = ['sphinxcontrib.kana_text']
+ #kana_text_word_file = '~/.config/sphinx/word_list.txt'
+ #kana_text_word_list = ['ようご|用語^21', 'ぶんしょさくせい|文書作成^2222',]
+ #kana_text_indexer_mode = 'small'
+ #kana_text_on_genindex = False
+ - 'word_list.txt' is required for kana_text_word_file
+ - 'genindex.html' is required for kana_text_on_genindex = True.
+ - both parameters are valid only against genindex.html.
+rst file:
+ ようごいち|用語壱^212
+ 用語1の説明。
+ 夜空に浮かぶ\ :index:`あまた|数多^21`\ の星々が\ :kana:`きらめいて|煌めいて^2c`\ いる。
+build:
+ $ make html
+
+%package -n python3-sphinxcontrib.kana-text
+Summary: KanaText class extends the functionality of Text class, for someone who use index/glossary directives.
+Provides: python-sphinxcontrib.kana-text
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-sphinxcontrib.kana-text
+installtion
+ $ pip install sphindexer sphinxcontrib.kana_text
+conf.py:
+ extensions = ['sphinxcontrib.kana_text']
+ #kana_text_word_file = '~/.config/sphinx/word_list.txt'
+ #kana_text_word_list = ['ようご|用語^21', 'ぶんしょさくせい|文書作成^2222',]
+ #kana_text_indexer_mode = 'small'
+ #kana_text_on_genindex = False
+ - 'word_list.txt' is required for kana_text_word_file
+ - 'genindex.html' is required for kana_text_on_genindex = True.
+ - both parameters are valid only against genindex.html.
+rst file:
+ ようごいち|用語壱^212
+ 用語1の説明。
+ 夜空に浮かぶ\ :index:`あまた|数多^21`\ の星々が\ :kana:`きらめいて|煌めいて^2c`\ いる。
+build:
+ $ make html
+
+%package help
+Summary: Development documents and examples for sphinxcontrib.kana-text
+Provides: python3-sphinxcontrib.kana-text-doc
+%description help
+installtion
+ $ pip install sphindexer sphinxcontrib.kana_text
+conf.py:
+ extensions = ['sphinxcontrib.kana_text']
+ #kana_text_word_file = '~/.config/sphinx/word_list.txt'
+ #kana_text_word_list = ['ようご|用語^21', 'ぶんしょさくせい|文書作成^2222',]
+ #kana_text_indexer_mode = 'small'
+ #kana_text_on_genindex = False
+ - 'word_list.txt' is required for kana_text_word_file
+ - 'genindex.html' is required for kana_text_on_genindex = True.
+ - both parameters are valid only against genindex.html.
+rst file:
+ ようごいち|用語壱^212
+ 用語1の説明。
+ 夜空に浮かぶ\ :index:`あまた|数多^21`\ の星々が\ :kana:`きらめいて|煌めいて^2c`\ いる。
+build:
+ $ make html
+
+%prep
+%autosetup -n sphinxcontrib.kana-text-0.32.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-sphinxcontrib.kana-text -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.32.1-1
+- Package Spec generated