summaryrefslogtreecommitdiff
path: root/python-splunk-add-on-ucc-framework.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-splunk-add-on-ucc-framework.spec')
-rw-r--r--python-splunk-add-on-ucc-framework.spec148
1 files changed, 148 insertions, 0 deletions
diff --git a/python-splunk-add-on-ucc-framework.spec b/python-splunk-add-on-ucc-framework.spec
new file mode 100644
index 0000000..aa62a39
--- /dev/null
+++ b/python-splunk-add-on-ucc-framework.spec
@@ -0,0 +1,148 @@
+%global _empty_manifest_terminate_build 0
+Name: python-splunk-add-on-ucc-framework
+Version: 5.24.0
+Release: 1
+Summary: Splunk Add-on SDK formerly UCC is a build and code generation framework
+License: Apache-2.0
+URL: https://github.com/splunk/addonfactory-ucc-generator
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/62/65ad6ee39025302b6fe1ce6e20dc6594a10e05a9e6f99282d73de9ced028/splunk_add_on_ucc_framework-5.24.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-jinja2
+Requires: python3-addonfactory-splunk-conf-parser-lib
+Requires: python3-dunamai
+Requires: python3-jsonschema
+Requires: python3-PyYAML
+Requires: python3-cookiecutter
+Requires: python3-openapi3
+
+%description
+# splunk-add-on-ucc-framework
+
+![PyPI](https://img.shields.io/pypi/v/splunk-add-on-ucc-framework)
+![Python](https://img.shields.io/pypi/pyversions/splunk-add-on-ucc-framework.svg)
+
+## What is UCC?
+
+UCC stands for Universal Configuration Console. It is a service for generating Splunk Add-ons which is easily customizable and flexible.
+UCC provides basic UI template for creating Addon's UI. It is helpful to control the activity by using hooks and other functionalities.
+
+## Usage
+
+For full usage instructions, please visit the [documentation](https://splunk.github.io/addonfactory-ucc-generator/).
+
+## Communication channels
+
+If you are a Splunker use: https://splunk.slack.com/archives/C03T8QCHBTJ
+
+If you are a part of the community use: https://splunk-usergroups.slack.com/archives/C03SG3ZL4S1
+
+## Contributing Guidelines
+
+Go to [Contributing Guidelines](https://splunk.github.io/addonfactory-ucc-generator/contributing/).
+
+
+%package -n python3-splunk-add-on-ucc-framework
+Summary: Splunk Add-on SDK formerly UCC is a build and code generation framework
+Provides: python-splunk-add-on-ucc-framework
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-splunk-add-on-ucc-framework
+# splunk-add-on-ucc-framework
+
+![PyPI](https://img.shields.io/pypi/v/splunk-add-on-ucc-framework)
+![Python](https://img.shields.io/pypi/pyversions/splunk-add-on-ucc-framework.svg)
+
+## What is UCC?
+
+UCC stands for Universal Configuration Console. It is a service for generating Splunk Add-ons which is easily customizable and flexible.
+UCC provides basic UI template for creating Addon's UI. It is helpful to control the activity by using hooks and other functionalities.
+
+## Usage
+
+For full usage instructions, please visit the [documentation](https://splunk.github.io/addonfactory-ucc-generator/).
+
+## Communication channels
+
+If you are a Splunker use: https://splunk.slack.com/archives/C03T8QCHBTJ
+
+If you are a part of the community use: https://splunk-usergroups.slack.com/archives/C03SG3ZL4S1
+
+## Contributing Guidelines
+
+Go to [Contributing Guidelines](https://splunk.github.io/addonfactory-ucc-generator/contributing/).
+
+
+%package help
+Summary: Development documents and examples for splunk-add-on-ucc-framework
+Provides: python3-splunk-add-on-ucc-framework-doc
+%description help
+# splunk-add-on-ucc-framework
+
+![PyPI](https://img.shields.io/pypi/v/splunk-add-on-ucc-framework)
+![Python](https://img.shields.io/pypi/pyversions/splunk-add-on-ucc-framework.svg)
+
+## What is UCC?
+
+UCC stands for Universal Configuration Console. It is a service for generating Splunk Add-ons which is easily customizable and flexible.
+UCC provides basic UI template for creating Addon's UI. It is helpful to control the activity by using hooks and other functionalities.
+
+## Usage
+
+For full usage instructions, please visit the [documentation](https://splunk.github.io/addonfactory-ucc-generator/).
+
+## Communication channels
+
+If you are a Splunker use: https://splunk.slack.com/archives/C03T8QCHBTJ
+
+If you are a part of the community use: https://splunk-usergroups.slack.com/archives/C03SG3ZL4S1
+
+## Contributing Guidelines
+
+Go to [Contributing Guidelines](https://splunk.github.io/addonfactory-ucc-generator/contributing/).
+
+
+%prep
+%autosetup -n splunk-add-on-ucc-framework-5.24.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-splunk-add-on-ucc-framework -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 5.24.0-1
+- Package Spec generated