summaryrefslogtreecommitdiff
path: root/python-strangecase.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-strangecase.spec')
-rw-r--r--python-strangecase.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-strangecase.spec b/python-strangecase.spec
new file mode 100644
index 0000000..f94b457
--- /dev/null
+++ b/python-strangecase.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-StrangeCase
+Version: 4.6.8
+Release: 1
+Summary: A straightforward python static site generator.
+License: BSD
+URL: https://github.com/colinta/StrangeCase
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/97/0f8d27da4fcf805895d9657a885d131245da80eb305b7db226ecf45aa2d9/StrangeCase-4.6.8.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-StrangeCase
+Summary: A straightforward python static site generator.
+Provides: python-StrangeCase
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-StrangeCase
+
+
+%package help
+Summary: Development documents and examples for StrangeCase
+Provides: python3-StrangeCase-doc
+%description help
+
+
+%prep
+%autosetup -n StrangeCase-4.6.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-StrangeCase -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 4.6.8-1
+- Package Spec generated