summaryrefslogtreecommitdiff
path: root/python-strongtyping.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-strongtyping.spec')
-rw-r--r--python-strongtyping.spec132
1 files changed, 132 insertions, 0 deletions
diff --git a/python-strongtyping.spec b/python-strongtyping.spec
new file mode 100644
index 0000000..6c11d8e
--- /dev/null
+++ b/python-strongtyping.spec
@@ -0,0 +1,132 @@
+%global _empty_manifest_terminate_build 0
+Name: python-strongtyping
+Version: 3.10.7
+Release: 1
+Summary: Decorator which checks whether the function is called with the correct type of parameters
+License: MIT
+URL: https://strongtyping.readthedocs.io/en/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d2/fa/0e29a3519f8cd7c0c10962375670e1fde97fa3733ec298e2ebd6b7bedd0d/strongtyping-3.10.7.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Python 3.10](https://img.shields.io/badge/python-3.10-blue.svg)](https://www.python.org/downloads/release/python-3100/)
+[![Python 3.11](https://img.shields.io/badge/python-3.11-blue.svg)](https://www.python.org/downloads/release/python-3110/)
+[![PyPI version](https://badge.fury.io/py/strongtyping.svg)](https://badge.fury.io/py/strongtyping)
+![Python application](https://github.com/FelixTheC/strongtyping/workflows/Python%20application/badge.svg)
+![Python tox](https://github.com/FelixTheC/strongtyping/workflows/Python%20tox/badge.svg)
+![image](https://codecov.io/gh/FelixTheC/strongtyping/graph/badge.svg)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![Documentation Status](https://readthedocs.org/projects/strongtyping/badge/?version=latest)](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
+[![](https://img.shields.io/pypi/dm/strongtyping.svg)](https://pypi.org/project/strongtyping/)
+
+
+# Strong Typing
+<p>Decorator which <b>checks at Runtime</b> whether the function is called with the correct type of parameters.<br>
+And <b><em>raises</em> TypeMisMatch</b> if the used parameters in a function call where invalid.</p>
+
+# This is the release for Python-3.10 and above
+- If you need a different version please checkout the release Tags 2.\*.*
+
+## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
+
+
+%package -n python3-strongtyping
+Summary: Decorator which checks whether the function is called with the correct type of parameters
+Provides: python-strongtyping
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-strongtyping
+[![Python 3.10](https://img.shields.io/badge/python-3.10-blue.svg)](https://www.python.org/downloads/release/python-3100/)
+[![Python 3.11](https://img.shields.io/badge/python-3.11-blue.svg)](https://www.python.org/downloads/release/python-3110/)
+[![PyPI version](https://badge.fury.io/py/strongtyping.svg)](https://badge.fury.io/py/strongtyping)
+![Python application](https://github.com/FelixTheC/strongtyping/workflows/Python%20application/badge.svg)
+![Python tox](https://github.com/FelixTheC/strongtyping/workflows/Python%20tox/badge.svg)
+![image](https://codecov.io/gh/FelixTheC/strongtyping/graph/badge.svg)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![Documentation Status](https://readthedocs.org/projects/strongtyping/badge/?version=latest)](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
+[![](https://img.shields.io/pypi/dm/strongtyping.svg)](https://pypi.org/project/strongtyping/)
+
+
+# Strong Typing
+<p>Decorator which <b>checks at Runtime</b> whether the function is called with the correct type of parameters.<br>
+And <b><em>raises</em> TypeMisMatch</b> if the used parameters in a function call where invalid.</p>
+
+# This is the release for Python-3.10 and above
+- If you need a different version please checkout the release Tags 2.\*.*
+
+## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
+
+
+%package help
+Summary: Development documents and examples for strongtyping
+Provides: python3-strongtyping-doc
+%description help
+[![Python 3.10](https://img.shields.io/badge/python-3.10-blue.svg)](https://www.python.org/downloads/release/python-3100/)
+[![Python 3.11](https://img.shields.io/badge/python-3.11-blue.svg)](https://www.python.org/downloads/release/python-3110/)
+[![PyPI version](https://badge.fury.io/py/strongtyping.svg)](https://badge.fury.io/py/strongtyping)
+![Python application](https://github.com/FelixTheC/strongtyping/workflows/Python%20application/badge.svg)
+![Python tox](https://github.com/FelixTheC/strongtyping/workflows/Python%20tox/badge.svg)
+![image](https://codecov.io/gh/FelixTheC/strongtyping/graph/badge.svg)
+[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Imports: isort](https://img.shields.io/badge/%20imports-isort-%231674b1?style=flat&labelColor=ef8336)](https://pycqa.github.io/isort/)
+[![Documentation Status](https://readthedocs.org/projects/strongtyping/badge/?version=latest)](https://strongtyping.readthedocs.io/en/latest/?badge=latest)
+[![](https://img.shields.io/pypi/dm/strongtyping.svg)](https://pypi.org/project/strongtyping/)
+
+
+# Strong Typing
+<p>Decorator which <b>checks at Runtime</b> whether the function is called with the correct type of parameters.<br>
+And <b><em>raises</em> TypeMisMatch</b> if the used parameters in a function call where invalid.</p>
+
+# This is the release for Python-3.10 and above
+- If you need a different version please checkout the release Tags 2.\*.*
+
+## [Docs have been moved to 'readthedocs'](https://strongtyping.readthedocs.io/en/latest/#the-solution)
+
+
+%prep
+%autosetup -n strongtyping-3.10.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-strongtyping -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.7-1
+- Package Spec generated