summaryrefslogtreecommitdiff
path: root/python-stups-pierone.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-stups-pierone.spec')
-rw-r--r--python-stups-pierone.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-stups-pierone.spec b/python-stups-pierone.spec
new file mode 100644
index 0000000..cbc62b0
--- /dev/null
+++ b/python-stups-pierone.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-stups-pierone
+Version: 1.1.54
+Release: 1
+Summary: Pier One Docker registry CLI
+License: Apache License 2.0
+URL: https://github.com/zalando-stups/pierone-cli
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4a/9a/cdc16e91bd1b3b653a1733ed72e00bf4f6ebe9a20991ce46998398840413/stups-pierone-1.1.54.tar.gz
+BuildArch: noarch
+
+Requires: python3-clickclick
+Requires: python3-requests
+Requires: python3-stups-zign
+Requires: python3-stups-cli-support
+
+%description
+
+
+%package -n python3-stups-pierone
+Summary: Pier One Docker registry CLI
+Provides: python-stups-pierone
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-stups-pierone
+
+
+%package help
+Summary: Development documents and examples for stups-pierone
+Provides: python3-stups-pierone-doc
+%description help
+
+
+%prep
+%autosetup -n stups-pierone-1.1.54
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-stups-pierone -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.54-1
+- Package Spec generated