summaryrefslogtreecommitdiff
path: root/python-tables.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tables.spec')
-rw-r--r--python-tables.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/python-tables.spec b/python-tables.spec
new file mode 100644
index 0000000..6ea0deb
--- /dev/null
+++ b/python-tables.spec
@@ -0,0 +1,108 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tables
+Version: 3.8.0
+Release: 1
+Summary: Hierarchical datasets for Python
+License: BSD 3-Clause License
+URL: https://www.pytables.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/42/07b37c0c64a13f005bfe95c8eec5f454fc8dd2caf85fa28add5b2a35b7ab/tables-3.8.0.tar.gz
+
+Requires: python3-cython
+Requires: python3-numpy
+Requires: python3-numexpr
+Requires: python3-blosc2
+Requires: python3-packaging
+Requires: python3-py-cpuinfo
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-numpydoc
+Requires: python3-ipython
+
+%description
+
+PyTables is a package for managing hierarchical datasets and
+designed to efficiently cope with extremely large amounts of
+data. PyTables is built on top of the HDF5 library and the
+NumPy package and features an object-oriented interface
+that, combined with C-code generated from Cython sources,
+makes of it a fast, yet extremely easy to use tool for
+interactively save and retrieve large amounts of data.
+
+
+%package -n python3-tables
+Summary: Hierarchical datasets for Python
+Provides: python-tables
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-tables
+
+PyTables is a package for managing hierarchical datasets and
+designed to efficiently cope with extremely large amounts of
+data. PyTables is built on top of the HDF5 library and the
+NumPy package and features an object-oriented interface
+that, combined with C-code generated from Cython sources,
+makes of it a fast, yet extremely easy to use tool for
+interactively save and retrieve large amounts of data.
+
+
+%package help
+Summary: Development documents and examples for tables
+Provides: python3-tables-doc
+%description help
+
+PyTables is a package for managing hierarchical datasets and
+designed to efficiently cope with extremely large amounts of
+data. PyTables is built on top of the HDF5 library and the
+NumPy package and features an object-oriented interface
+that, combined with C-code generated from Cython sources,
+makes of it a fast, yet extremely easy to use tool for
+interactively save and retrieve large amounts of data.
+
+
+%prep
+%autosetup -n tables-3.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tables -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.8.0-1
+- Package Spec generated