summaryrefslogtreecommitdiff
path: root/python-tabulate.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tabulate.spec')
-rw-r--r--python-tabulate.spec100
1 files changed, 100 insertions, 0 deletions
diff --git a/python-tabulate.spec b/python-tabulate.spec
new file mode 100644
index 0000000..48d1b19
--- /dev/null
+++ b/python-tabulate.spec
@@ -0,0 +1,100 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tabulate
+Version: 0.9.0
+Release: 1
+Summary: Pretty-print tabular data
+License: MIT
+URL: https://github.com/astanin/python-tabulate
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/fe/802052aecb21e3797b8f7902564ab6ea0d60ff8ca23952079064155d1ae1/tabulate-0.9.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-wcwidth
+
+%description
+Pretty-print tabular data in Python, a library and a command-line
+utility.
+The main use cases of the library are:
+- printing small tables without hassle: just one function call,
+ formatting is guided by the data itself
+- authoring tabular data for lightweight plain-text markup: multiple
+ output formats suitable for further editing or transformation
+- readable presentation of mixed textual and numeric data: smart
+ column alignment, configurable number formatting, alignment by a
+ decimal point
+
+%package -n python3-tabulate
+Summary: Pretty-print tabular data
+Provides: python-tabulate
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tabulate
+Pretty-print tabular data in Python, a library and a command-line
+utility.
+The main use cases of the library are:
+- printing small tables without hassle: just one function call,
+ formatting is guided by the data itself
+- authoring tabular data for lightweight plain-text markup: multiple
+ output formats suitable for further editing or transformation
+- readable presentation of mixed textual and numeric data: smart
+ column alignment, configurable number formatting, alignment by a
+ decimal point
+
+%package help
+Summary: Development documents and examples for tabulate
+Provides: python3-tabulate-doc
+%description help
+Pretty-print tabular data in Python, a library and a command-line
+utility.
+The main use cases of the library are:
+- printing small tables without hassle: just one function call,
+ formatting is guided by the data itself
+- authoring tabular data for lightweight plain-text markup: multiple
+ output formats suitable for further editing or transformation
+- readable presentation of mixed textual and numeric data: smart
+ column alignment, configurable number formatting, alignment by a
+ decimal point
+
+%prep
+%autosetup -n tabulate-0.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tabulate -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
+- Package Spec generated