summaryrefslogtreecommitdiff
path: root/python-tdda.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tdda.spec')
-rw-r--r--python-tdda.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-tdda.spec b/python-tdda.spec
new file mode 100644
index 0000000..ba12634
--- /dev/null
+++ b/python-tdda.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tdda
+Version: 2.0.9
+Release: 1
+Summary: Test Driven Data Analysis
+License: MIT
+URL: http://www.stochasticsolutions.com
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/82/6f/69a68da009941824663c3d71fe2b9f8aeeefcd4dcf2b73b608bc67a2d8b1/tdda-2.0.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-pandas
+
+%description
+
+
+%package -n python3-tdda
+Summary: Test Driven Data Analysis
+Provides: python-tdda
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tdda
+
+
+%package help
+Summary: Development documents and examples for tdda
+Provides: python3-tdda-doc
+%description help
+
+
+%prep
+%autosetup -n tdda-2.0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tdda -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.9-1
+- Package Spec generated