summaryrefslogtreecommitdiff
path: root/python-telesign.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-telesign.spec')
-rw-r--r--python-telesign.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-telesign.spec b/python-telesign.spec
new file mode 100644
index 0000000..d52bf54
--- /dev/null
+++ b/python-telesign.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-telesign
+Version: 2.2.2
+Release: 1
+Summary: TeleSign SDK
+License: MIT
+URL: https://github.com/telesign/python_telesign
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/99/ef1574d164077c0cff35cf87dfd69e17ededdc3e4a6b73002543b221b195/telesign-2.2.2.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-telesign
+Summary: TeleSign SDK
+Provides: python-telesign
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-telesign
+
+
+%package help
+Summary: Development documents and examples for telesign
+Provides: python3-telesign-doc
+%description help
+
+
+%prep
+%autosetup -n telesign-2.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-telesign -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.2-1
+- Package Spec generated