summaryrefslogtreecommitdiff
path: root/python-text2emotion.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-text2emotion.spec')
-rw-r--r--python-text2emotion.spec197
1 files changed, 197 insertions, 0 deletions
diff --git a/python-text2emotion.spec b/python-text2emotion.spec
new file mode 100644
index 0000000..03b9e24
--- /dev/null
+++ b/python-text2emotion.spec
@@ -0,0 +1,197 @@
+%global _empty_manifest_terminate_build 0
+Name: python-text2emotion
+Version: 0.0.5
+Release: 1
+Summary: Detecting emotions behind the text, text2emotion package will help you to understand the emotions in textual meassages.
+License: MIT
+URL: https://github.com/aman2656/text2emotion-library
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b0/47/c63fd37b02ebfdfaf7aa365d40b2ac357814a820b692dc1a652a6cbc8964/text2emotion-0.0.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-nltk
+Requires: python3-emoji
+
+%description
+# What is emotion?
+Emotion is a biological state associated with the nervous system brought on by neurophysiological changes variously associated with thoughts, feelings, behavioural responses, and a degree of pleasure or displeasure.
+(Source: Wikipedia)
+
+Human being can easily identify the emotions from text and experience it. But what about the machines, are they able to identify the emotions from text?
+
+#### text2emotion is the python package which will help you to extract the emotions from the content.
+
+- Processes any textual message and recognize the emotions embedded in it.
+- Compatible with 5 different emotion categories as Happy, Angry, Sad, Surprise and Fear.
+
+## Features
+> ##### 1. Text Pre-processing
+> At first we have the major goal to perform data cleaning and make the content suitable for emotion analysis.
+> - Remove the unwanted textual part from the message.
+> - Perform the natural language processing techniques.
+> - Bring out the well pre-processed text from the text pre-processing.
+> ##### 2. Emotion Investigation
+> Detect emotion from every word that we got from pre-processed text and take a count of it for further analytical process.
+> - Find the appropriate words that express emotions or feelings.
+> - Check the emotion category of each word.
+> - Store the count of emotions relevant to the words found.
+> ##### 3. Emotion Analysis
+> After emotion investigation, there is the time of getting the significant output for the textual message we input earlier.
+> - The output will be in the form of dictionary.
+> - There will be keys as emotion categories and values as emotion score.
+> - Higher the score of a particular emotion category, we can conclude that the message belongs to that category.
+
+## How to use?
+#### [Check Demo on Colab](https://bit.ly/3hlXujZ)
+
+## App Deployment
+Here's the code implementation with **Streamlit App** for the users.
+1. Enter the text.
+2. Hit the submit button.
+3. Tada!! Get the output in visual form.
+#### [Check Demo of App](https://text2emotion.herokuapp.com/)
+
+Let's experience the library, test your multiple use cases on web app and check whether the library performs as per your expectations.
+
+
+
+
+%package -n python3-text2emotion
+Summary: Detecting emotions behind the text, text2emotion package will help you to understand the emotions in textual meassages.
+Provides: python-text2emotion
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-text2emotion
+# What is emotion?
+Emotion is a biological state associated with the nervous system brought on by neurophysiological changes variously associated with thoughts, feelings, behavioural responses, and a degree of pleasure or displeasure.
+(Source: Wikipedia)
+
+Human being can easily identify the emotions from text and experience it. But what about the machines, are they able to identify the emotions from text?
+
+#### text2emotion is the python package which will help you to extract the emotions from the content.
+
+- Processes any textual message and recognize the emotions embedded in it.
+- Compatible with 5 different emotion categories as Happy, Angry, Sad, Surprise and Fear.
+
+## Features
+> ##### 1. Text Pre-processing
+> At first we have the major goal to perform data cleaning and make the content suitable for emotion analysis.
+> - Remove the unwanted textual part from the message.
+> - Perform the natural language processing techniques.
+> - Bring out the well pre-processed text from the text pre-processing.
+> ##### 2. Emotion Investigation
+> Detect emotion from every word that we got from pre-processed text and take a count of it for further analytical process.
+> - Find the appropriate words that express emotions or feelings.
+> - Check the emotion category of each word.
+> - Store the count of emotions relevant to the words found.
+> ##### 3. Emotion Analysis
+> After emotion investigation, there is the time of getting the significant output for the textual message we input earlier.
+> - The output will be in the form of dictionary.
+> - There will be keys as emotion categories and values as emotion score.
+> - Higher the score of a particular emotion category, we can conclude that the message belongs to that category.
+
+## How to use?
+#### [Check Demo on Colab](https://bit.ly/3hlXujZ)
+
+## App Deployment
+Here's the code implementation with **Streamlit App** for the users.
+1. Enter the text.
+2. Hit the submit button.
+3. Tada!! Get the output in visual form.
+#### [Check Demo of App](https://text2emotion.herokuapp.com/)
+
+Let's experience the library, test your multiple use cases on web app and check whether the library performs as per your expectations.
+
+
+
+
+%package help
+Summary: Development documents and examples for text2emotion
+Provides: python3-text2emotion-doc
+%description help
+# What is emotion?
+Emotion is a biological state associated with the nervous system brought on by neurophysiological changes variously associated with thoughts, feelings, behavioural responses, and a degree of pleasure or displeasure.
+(Source: Wikipedia)
+
+Human being can easily identify the emotions from text and experience it. But what about the machines, are they able to identify the emotions from text?
+
+#### text2emotion is the python package which will help you to extract the emotions from the content.
+
+- Processes any textual message and recognize the emotions embedded in it.
+- Compatible with 5 different emotion categories as Happy, Angry, Sad, Surprise and Fear.
+
+## Features
+> ##### 1. Text Pre-processing
+> At first we have the major goal to perform data cleaning and make the content suitable for emotion analysis.
+> - Remove the unwanted textual part from the message.
+> - Perform the natural language processing techniques.
+> - Bring out the well pre-processed text from the text pre-processing.
+> ##### 2. Emotion Investigation
+> Detect emotion from every word that we got from pre-processed text and take a count of it for further analytical process.
+> - Find the appropriate words that express emotions or feelings.
+> - Check the emotion category of each word.
+> - Store the count of emotions relevant to the words found.
+> ##### 3. Emotion Analysis
+> After emotion investigation, there is the time of getting the significant output for the textual message we input earlier.
+> - The output will be in the form of dictionary.
+> - There will be keys as emotion categories and values as emotion score.
+> - Higher the score of a particular emotion category, we can conclude that the message belongs to that category.
+
+## How to use?
+#### [Check Demo on Colab](https://bit.ly/3hlXujZ)
+
+## App Deployment
+Here's the code implementation with **Streamlit App** for the users.
+1. Enter the text.
+2. Hit the submit button.
+3. Tada!! Get the output in visual form.
+#### [Check Demo of App](https://text2emotion.herokuapp.com/)
+
+Let's experience the library, test your multiple use cases on web app and check whether the library performs as per your expectations.
+
+
+
+
+%prep
+%autosetup -n text2emotion-0.0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-text2emotion -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.5-1
+- Package Spec generated