summaryrefslogtreecommitdiff
path: root/python-texttable-fixed.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-texttable-fixed.spec')
-rw-r--r--python-texttable-fixed.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-texttable-fixed.spec b/python-texttable-fixed.spec
new file mode 100644
index 0000000..6242ee6
--- /dev/null
+++ b/python-texttable-fixed.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-texttable-fixed
+Version: 0.8.3
+Release: 1
+Summary: module for creating simple ASCII tables
+License: LGPL
+URL: UNKNOWN
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/c2/654b12b38cb3ded68d9387cac2eb70db1f5140b12d0cb4955789297e79f5/texttable-fixed-0.8.3.tar.gz
+BuildArch: noarch
+
+
+%description
+texttable is a module to generate a formatted text table, using ASCII
+characters. texttable-fixed is a fork of
+https://github.com/bufordtaylor/python-texttable that uploads the latest,
+correct version (0.8.3) to PyPi as the main texttable module does not
+have the correct sources.
+
+%package -n python3-texttable-fixed
+Summary: module for creating simple ASCII tables
+Provides: python-texttable-fixed
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-texttable-fixed
+texttable is a module to generate a formatted text table, using ASCII
+characters. texttable-fixed is a fork of
+https://github.com/bufordtaylor/python-texttable that uploads the latest,
+correct version (0.8.3) to PyPi as the main texttable module does not
+have the correct sources.
+
+%package help
+Summary: Development documents and examples for texttable-fixed
+Provides: python3-texttable-fixed-doc
+%description help
+texttable is a module to generate a formatted text table, using ASCII
+characters. texttable-fixed is a fork of
+https://github.com/bufordtaylor/python-texttable that uploads the latest,
+correct version (0.8.3) to PyPi as the main texttable module does not
+have the correct sources.
+
+%prep
+%autosetup -n texttable-fixed-0.8.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-texttable-fixed -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.3-1
+- Package Spec generated