summaryrefslogtreecommitdiff
path: root/python-thespian.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 17:20:58 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 17:20:58 +0000
commit4b35d6e2eb936022bde10ea69def2dab40fdf42e (patch)
tree0c9ca2c219565e0c1d03dd009fc5254c02a8990e /python-thespian.spec
parent60b7306331af83b2d95c5108c1e324ad50e94efc (diff)
automatic import of python-thespian
Diffstat (limited to 'python-thespian.spec')
-rw-r--r--python-thespian.spec147
1 files changed, 147 insertions, 0 deletions
diff --git a/python-thespian.spec b/python-thespian.spec
new file mode 100644
index 0000000..93c5c51
--- /dev/null
+++ b/python-thespian.spec
@@ -0,0 +1,147 @@
+%global _empty_manifest_terminate_build 0
+Name: python-thespian
+Version: 3.10.7
+Release: 1
+Summary: Python Actor concurrency library
+License: MIT
+URL: http://thespianpy.com
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/55/b0/97c08d8909d4e54d73b3567bb5462cff59008beb80817f69d9b7c1566a96/thespian-3.10.7.zip
+BuildArch: noarch
+
+
+%description
+
+
+Thespian is a Python library providing a framework for developing
+concurrent, distributed, fault tolerant applications.
+
+Thespian is built on the Actor Model which allows applications to be
+written as a group of independently executing but cooperating
+"Actors" which communicate via messages. These Actors run within
+the Actor System provided by the Thespian library.
+
+ * Concurrent
+ * Distributed
+ * Fault Tolerant
+ * Scalable
+ * Location independent
+
+Actor programming is broadly applicable and it is ideally suited
+for Cloud-based applications as well, where compute nodes are
+added and removed from the environment dynamically.
+
+ * More Information: http://thespianpy.com
+ * Release Notes: http://thespianpy.com/doc/releases.html
+
+
+
+
+
+%package -n python3-thespian
+Summary: Python Actor concurrency library
+Provides: python-thespian
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-thespian
+
+
+Thespian is a Python library providing a framework for developing
+concurrent, distributed, fault tolerant applications.
+
+Thespian is built on the Actor Model which allows applications to be
+written as a group of independently executing but cooperating
+"Actors" which communicate via messages. These Actors run within
+the Actor System provided by the Thespian library.
+
+ * Concurrent
+ * Distributed
+ * Fault Tolerant
+ * Scalable
+ * Location independent
+
+Actor programming is broadly applicable and it is ideally suited
+for Cloud-based applications as well, where compute nodes are
+added and removed from the environment dynamically.
+
+ * More Information: http://thespianpy.com
+ * Release Notes: http://thespianpy.com/doc/releases.html
+
+
+
+
+
+%package help
+Summary: Development documents and examples for thespian
+Provides: python3-thespian-doc
+%description help
+
+
+Thespian is a Python library providing a framework for developing
+concurrent, distributed, fault tolerant applications.
+
+Thespian is built on the Actor Model which allows applications to be
+written as a group of independently executing but cooperating
+"Actors" which communicate via messages. These Actors run within
+the Actor System provided by the Thespian library.
+
+ * Concurrent
+ * Distributed
+ * Fault Tolerant
+ * Scalable
+ * Location independent
+
+Actor programming is broadly applicable and it is ideally suited
+for Cloud-based applications as well, where compute nodes are
+added and removed from the environment dynamically.
+
+ * More Information: http://thespianpy.com
+ * Release Notes: http://thespianpy.com/doc/releases.html
+
+
+
+
+
+%prep
+%autosetup -n thespian-3.10.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-thespian -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.10.7-1
+- Package Spec generated