summaryrefslogtreecommitdiff
path: root/python-tiddlyweb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tiddlyweb.spec')
-rw-r--r--python-tiddlyweb.spec138
1 files changed, 138 insertions, 0 deletions
diff --git a/python-tiddlyweb.spec b/python-tiddlyweb.spec
new file mode 100644
index 0000000..ee98f16
--- /dev/null
+++ b/python-tiddlyweb.spec
@@ -0,0 +1,138 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tiddlyweb
+Version: 2.4.3
+Release: 1
+Summary: An optionally headless, extensible HTTP datastore for tiddlers: bits of stuff.
+License: BSD License
+URL: http://pypi.python.org/pypi/tiddlyweb
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/31/99/883b2b1dad15e0c522bb1fbf9f37d966db791a130e330e916f56087c2e63/tiddlyweb-2.4.3.tar.gz
+BuildArch: noarch
+
+
+%description
+TiddlyWeb is an open source HTTP API for storing and accessing flexible
+and composable microcontent. It is also a toolkit for tiddlers on the web.
+Tiddlers are small chunks of optionally structured content
+with their own URI. The concept comes from `TiddlyWiki <http://tiddlywiki.com>`_.
+TiddlyWeb can provide the basis of a `server side for TiddlyWiki
+<http://pypi.python.org/pypi/tiddlywebwiki>`_. TiddlyWeb provides:
+* an abstract model (with default implementations) for:
+ * authentication and authorization
+ * entity storage
+ * entity and collection serialization
+* a straightforward extension model via plugins
+* an implementation of authenticated recipes and bags allowing
+ access to dynamically created and filtered collections of tiddlers
+* a clean and pragmatic HTTP API
+The system is designed so that parts that are not optimal for a
+particular installation can be easily improved or swapped out via
+plugins.
+While TiddlyWeb was initially designed as a TiddlyWiki server-side
+it can also be used as a generic data store and platform. The platform
+builds on concepts learned from TiddlyWiki, primarily the concept of
+the tiddler: a small chunk of data used to build up a greater whole.
+TiddlyWeb includes a command line tool called ``twanager``. Run ``twanager``
+without arguments for a list of available commands.
+
+%package -n python3-tiddlyweb
+Summary: An optionally headless, extensible HTTP datastore for tiddlers: bits of stuff.
+Provides: python-tiddlyweb
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tiddlyweb
+TiddlyWeb is an open source HTTP API for storing and accessing flexible
+and composable microcontent. It is also a toolkit for tiddlers on the web.
+Tiddlers are small chunks of optionally structured content
+with their own URI. The concept comes from `TiddlyWiki <http://tiddlywiki.com>`_.
+TiddlyWeb can provide the basis of a `server side for TiddlyWiki
+<http://pypi.python.org/pypi/tiddlywebwiki>`_. TiddlyWeb provides:
+* an abstract model (with default implementations) for:
+ * authentication and authorization
+ * entity storage
+ * entity and collection serialization
+* a straightforward extension model via plugins
+* an implementation of authenticated recipes and bags allowing
+ access to dynamically created and filtered collections of tiddlers
+* a clean and pragmatic HTTP API
+The system is designed so that parts that are not optimal for a
+particular installation can be easily improved or swapped out via
+plugins.
+While TiddlyWeb was initially designed as a TiddlyWiki server-side
+it can also be used as a generic data store and platform. The platform
+builds on concepts learned from TiddlyWiki, primarily the concept of
+the tiddler: a small chunk of data used to build up a greater whole.
+TiddlyWeb includes a command line tool called ``twanager``. Run ``twanager``
+without arguments for a list of available commands.
+
+%package help
+Summary: Development documents and examples for tiddlyweb
+Provides: python3-tiddlyweb-doc
+%description help
+TiddlyWeb is an open source HTTP API for storing and accessing flexible
+and composable microcontent. It is also a toolkit for tiddlers on the web.
+Tiddlers are small chunks of optionally structured content
+with their own URI. The concept comes from `TiddlyWiki <http://tiddlywiki.com>`_.
+TiddlyWeb can provide the basis of a `server side for TiddlyWiki
+<http://pypi.python.org/pypi/tiddlywebwiki>`_. TiddlyWeb provides:
+* an abstract model (with default implementations) for:
+ * authentication and authorization
+ * entity storage
+ * entity and collection serialization
+* a straightforward extension model via plugins
+* an implementation of authenticated recipes and bags allowing
+ access to dynamically created and filtered collections of tiddlers
+* a clean and pragmatic HTTP API
+The system is designed so that parts that are not optimal for a
+particular installation can be easily improved or swapped out via
+plugins.
+While TiddlyWeb was initially designed as a TiddlyWiki server-side
+it can also be used as a generic data store and platform. The platform
+builds on concepts learned from TiddlyWiki, primarily the concept of
+the tiddler: a small chunk of data used to build up a greater whole.
+TiddlyWeb includes a command line tool called ``twanager``. Run ``twanager``
+without arguments for a list of available commands.
+
+%prep
+%autosetup -n tiddlyweb-2.4.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tiddlyweb -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.3-1
+- Package Spec generated