summaryrefslogtreecommitdiff
path: root/python-tika.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tika.spec')
-rw-r--r--python-tika.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-tika.spec b/python-tika.spec
new file mode 100644
index 0000000..cdec720
--- /dev/null
+++ b/python-tika.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tika
+Version: 2.6.0
+Release: 1
+Summary: Apache Tika Python library
+License: Apache License version 2 ("ALv2")
+URL: http://github.com/chrismattmann/tika-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fd/b8/055ed37d6413fef4e4af99cd7e0edc4ddfb8fc167b730b25005d212e2049/tika-2.6.0.tar.gz
+BuildArch: noarch
+
+
+%description
+A Python port of the [Apache Tika](http://tika.apache.org/)
+library that makes Tika available using the
+[Tika REST Server](https://cwiki.apache.org/confluence/display/TIKA/TikaServer).
+This makes Apache Tika available as a Python library,
+installable via Setuptools, Pip and Easy Install.
+To use this library, you need to have Java 7+ installed on your
+system as tika-python starts up the Tika REST server in the
+background.
+Inspired by [Aptivate Tika](https://github.com/aptivate/python-tika).
+
+%package -n python3-tika
+Summary: Apache Tika Python library
+Provides: python-tika
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tika
+A Python port of the [Apache Tika](http://tika.apache.org/)
+library that makes Tika available using the
+[Tika REST Server](https://cwiki.apache.org/confluence/display/TIKA/TikaServer).
+This makes Apache Tika available as a Python library,
+installable via Setuptools, Pip and Easy Install.
+To use this library, you need to have Java 7+ installed on your
+system as tika-python starts up the Tika REST server in the
+background.
+Inspired by [Aptivate Tika](https://github.com/aptivate/python-tika).
+
+%package help
+Summary: Development documents and examples for tika
+Provides: python3-tika-doc
+%description help
+A Python port of the [Apache Tika](http://tika.apache.org/)
+library that makes Tika available using the
+[Tika REST Server](https://cwiki.apache.org/confluence/display/TIKA/TikaServer).
+This makes Apache Tika available as a Python library,
+installable via Setuptools, Pip and Easy Install.
+To use this library, you need to have Java 7+ installed on your
+system as tika-python starts up the Tika REST server in the
+background.
+Inspired by [Aptivate Tika](https://github.com/aptivate/python-tika).
+
+%prep
+%autosetup -n tika-2.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tika -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.0-1
+- Package Spec generated