summaryrefslogtreecommitdiff
path: root/python-tox-poetry.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-tox-poetry.spec')
-rw-r--r--python-tox-poetry.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-tox-poetry.spec b/python-tox-poetry.spec
new file mode 100644
index 0000000..7d878ae
--- /dev/null
+++ b/python-tox-poetry.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tox-poetry
+Version: 0.5.0
+Release: 1
+Summary: Tox poetry plugin
+License: MIT
+URL: https://github.com/tkukushkin/tox-poetry
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/f2/f7c8ccb8f946f6cce66bd6f59f7a9721a7266a0e22576b06f0067ab451bb/tox-poetry-0.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pluggy
+Requires: python3-toml
+Requires: python3-tox
+Requires: python3-tox
+Requires: python3-coverage
+Requires: python3-pytest
+Requires: python3-pycodestyle
+Requires: python3-pylint
+
+%description
+
+
+%package -n python3-tox-poetry
+Summary: Tox poetry plugin
+Provides: python-tox-poetry
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tox-poetry
+
+
+%package help
+Summary: Development documents and examples for tox-poetry
+Provides: python3-tox-poetry-doc
+%description help
+
+
+%prep
+%autosetup -n tox-poetry-0.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tox-poetry -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
+- Package Spec generated