summaryrefslogtreecommitdiff
path: root/python-trytond-account-tax-rule-country.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 12:51:14 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 12:51:14 +0000
commitcd72bf236269db94b48ac4abce718e1d32ffd2e4 (patch)
tree84b9f1a75cb81e73212af585952f04bc76aa1640 /python-trytond-account-tax-rule-country.spec
parentba4cdbf0b74a01888c171279eb7163c14140401c (diff)
automatic import of python-trytond-account-tax-rule-country
Diffstat (limited to 'python-trytond-account-tax-rule-country.spec')
-rw-r--r--python-trytond-account-tax-rule-country.spec181
1 files changed, 181 insertions, 0 deletions
diff --git a/python-trytond-account-tax-rule-country.spec b/python-trytond-account-tax-rule-country.spec
new file mode 100644
index 0000000..8eb382c
--- /dev/null
+++ b/python-trytond-account-tax-rule-country.spec
@@ -0,0 +1,181 @@
+%global _empty_manifest_terminate_build 0
+Name: python-trytond-account-tax-rule-country
+Version: 6.8.0
+Release: 1
+Summary: Tryton module to add countries on tax rules
+License: GPL-3
+URL: http://www.tryton.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/71/db/a4c0578d9ad41ad925c2b9ccb76b7f1585a67f3a177d885d7dd3dc5f2db3/trytond_account_tax_rule_country-6.8.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-trytond-account
+Requires: python3-trytond-country
+Requires: python3-trytond
+Requires: python3-trytond-account-invoice
+Requires: python3-trytond-sale
+Requires: python3-trytond-purchase
+Requires: python3-trytond-stock
+
+%description
+Account Tax Rule Country
+########################
+
+The account_tax_rule module extends the tax rule to add origin and destination
+countries and subdivisions as criteria.
+
+Tax Rule Line
+*************
+
+Four criteria fields are added:
+
+- From Country: The country of origin
+- From Subdivision: The subdivision of origin
+- To Country: The country of destination
+- To Subdivision: The subdivision of destination
+
+The countries are picked from the origin document:
+
+- Sale:
+
+ - The origin country and subdivision come from the address of the warehouse.
+ - The destination country and subdivision come from the shipping address.
+
+- Purchase:
+
+ - The origin country and subdivision come from the invoice address.
+ - The destination country and subdivision come from the address of the warehouse.
+
+- Stock Consignment:
+
+ - The origin country and subdivision come from the warehouse's address of the
+ location or the delivery address for returned customer shipment.
+ - The destination country and subdivision come from the warehouse's address
+ of the location or the delivery address for customer shipment.
+
+
+%package -n python3-trytond-account-tax-rule-country
+Summary: Tryton module to add countries on tax rules
+Provides: python-trytond-account-tax-rule-country
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-trytond-account-tax-rule-country
+Account Tax Rule Country
+########################
+
+The account_tax_rule module extends the tax rule to add origin and destination
+countries and subdivisions as criteria.
+
+Tax Rule Line
+*************
+
+Four criteria fields are added:
+
+- From Country: The country of origin
+- From Subdivision: The subdivision of origin
+- To Country: The country of destination
+- To Subdivision: The subdivision of destination
+
+The countries are picked from the origin document:
+
+- Sale:
+
+ - The origin country and subdivision come from the address of the warehouse.
+ - The destination country and subdivision come from the shipping address.
+
+- Purchase:
+
+ - The origin country and subdivision come from the invoice address.
+ - The destination country and subdivision come from the address of the warehouse.
+
+- Stock Consignment:
+
+ - The origin country and subdivision come from the warehouse's address of the
+ location or the delivery address for returned customer shipment.
+ - The destination country and subdivision come from the warehouse's address
+ of the location or the delivery address for customer shipment.
+
+
+%package help
+Summary: Development documents and examples for trytond-account-tax-rule-country
+Provides: python3-trytond-account-tax-rule-country-doc
+%description help
+Account Tax Rule Country
+########################
+
+The account_tax_rule module extends the tax rule to add origin and destination
+countries and subdivisions as criteria.
+
+Tax Rule Line
+*************
+
+Four criteria fields are added:
+
+- From Country: The country of origin
+- From Subdivision: The subdivision of origin
+- To Country: The country of destination
+- To Subdivision: The subdivision of destination
+
+The countries are picked from the origin document:
+
+- Sale:
+
+ - The origin country and subdivision come from the address of the warehouse.
+ - The destination country and subdivision come from the shipping address.
+
+- Purchase:
+
+ - The origin country and subdivision come from the invoice address.
+ - The destination country and subdivision come from the address of the warehouse.
+
+- Stock Consignment:
+
+ - The origin country and subdivision come from the warehouse's address of the
+ location or the delivery address for returned customer shipment.
+ - The destination country and subdivision come from the warehouse's address
+ of the location or the delivery address for customer shipment.
+
+
+%prep
+%autosetup -n trytond-account-tax-rule-country-6.8.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-trytond-account-tax-rule-country -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 6.8.0-1
+- Package Spec generated