summaryrefslogtreecommitdiff
path: root/python-tuya-iot-py-sdk.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 02:42:48 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 02:42:48 +0000
commitfe0bb8408c9b6e711f143b67fcd74440ea6de9ec (patch)
tree2fc68076e7be6247b99f44885f5fc8545d70e19e /python-tuya-iot-py-sdk.spec
parent68147a5e791d051f8fe1d18c268ae053f26d681c (diff)
automatic import of python-tuya-iot-py-sdk
Diffstat (limited to 'python-tuya-iot-py-sdk.spec')
-rw-r--r--python-tuya-iot-py-sdk.spec436
1 files changed, 436 insertions, 0 deletions
diff --git a/python-tuya-iot-py-sdk.spec b/python-tuya-iot-py-sdk.spec
new file mode 100644
index 0000000..f821909
--- /dev/null
+++ b/python-tuya-iot-py-sdk.spec
@@ -0,0 +1,436 @@
+%global _empty_manifest_terminate_build 0
+Name: python-tuya-iot-py-sdk
+Version: 0.6.6
+Release: 1
+Summary: A Python sdk for Tuya Open API, which provides IoT capabilities, maintained by Tuya official
+License: MIT
+URL: https://github.com/tuya/tuya-iot-app-sdk-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/32/51f5b7a9992c00f5857c272c1dce82216c0543232fcaffacfa5865d5da90/tuya-iot-py-sdk-0.6.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-paho-mqtt
+Requires: python3-requests
+Requires: python3-pycryptodome
+Requires: python3-websocket-client
+
+%description
+# Tuya IoT Python SDK
+
+
+
+![PyPI](https://img.shields.io/pypi/v/tuya-iot-py-sdk)
+
+![PyPI - Downloads](https://img.shields.io/pypi/dm/tuya-iot-py-sdk)
+
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/tuya-iot-py-sdk)
+
+
+A Python sdk for Tuya Open API, which provides basic IoT capabilities like device management, asset management and industry capabilities, helping you create IoT solutions.
+With diversified devices and industries, Tuya Cloud Development Platform opens basic IoT capabilities like device management, AI scenarios, and data analytics services, as well as industry capabilities, helping you create IoT solutions.
+
+
+## Features
+### Base APIs
+- TuyaOpenAPI
+ - connect
+ - is_connect
+ - get
+ - post
+ - put
+ - delete
+
+- TuyaOpenMQ
+ - start
+ - stop
+ - add_message_listener
+ - remove_message_listener
+
+### APIs
+- TuyaDeviceListener
+ - update_device
+ - add_device
+ - remove_device
+
+#### Device control
+- TuyaDeviceManager
+ - update_device_list_in_smart_home
+ - update_device_caches
+ - update_device_function_cache
+ - add_device_listener
+ - remove_device_listener
+ - get_device_info
+ - get_device_list_info
+ - remove_device
+ - remove_device_list
+ - get_factory_info
+ - factory_reset
+ - get_device_status
+ - get_device_list_status
+ - get_device_functions
+ - get_category_functions
+ - get_device_specification
+ - send_commands
+
+#### Home
+- TuyaHomeManager
+ - update_device_cache
+ - query_scenes
+ - trigger_scene
+ - query_infrared_devices
+ - trigger_infrared_commands
+
+#### Assets
+- TuyaAssetManager
+ - get_device_list
+ - get_asset_info
+ - get_asset_list
+
+
+
+## Possible scenarios
+
+
+
+- [HomeAssistant Tuya Plugin](https://github.com/tuya/tuya-home-assistant)
+
+- [Tuya Connector Python](https://github.com/tuya/tuya-connector-python)
+
+- [FHEM Tuya Plugin by fhempy](https://github.com/dominikkarall/fhempy/tree/master/FHEM/bindings/python/fhempy/lib/tuya_cloud)
+
+- ...
+
+
+## Prerequisite
+
+### Registration
+
+Please check [Tuya IoT Platform Configuration Guide](https://developer.tuya.com/en/docs/iot/Configuration_Guide_custom?id=Kamcfx6g5uyot) to register an account on the [Tuya IoT Platform](https://iot.tuya.com?_source=github), and get the required information. You need to create a Cloud project and complete the configuration of asset, user, and application. Then, you will get the **username**, **password**, **Access ID**, and **Access Secret**.
+
+## Usage
+
+## Installation
+
+`pip3 install tuya-iot-py-sdk`
+
+## Sample code
+
+[OpenAPI Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/device.py)
+
+[Open IoT Hub Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/mq.py)
+
+## Tuya Open API reference
+
+Tuya opens up a variety of APIs covering business scenarios such as device pairing, smart home management, device control, and scene automation. You can call APIs according to API integration documents to implement applications.
+
+For more information, see the [documentation](https://developer.tuya.com/en/docs/cloud/?_source=github).
+<!-- [Documentation > Cloud Development > API Reference](https://developer.tuya.com/docs/iot/open-api/api-reference/api-reference) -->
+
+## Issue feedback
+
+You can provide feedback on your issue via **Github Issue** or [Technical Ticket](https://service.console.tuya.com/).
+
+## License
+
+tuya-iot-py-sdk is available under the MIT license. Please see the [LICENSE](./LICENSE) file for more info.
+
+
+
+
+%package -n python3-tuya-iot-py-sdk
+Summary: A Python sdk for Tuya Open API, which provides IoT capabilities, maintained by Tuya official
+Provides: python-tuya-iot-py-sdk
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-tuya-iot-py-sdk
+# Tuya IoT Python SDK
+
+
+
+![PyPI](https://img.shields.io/pypi/v/tuya-iot-py-sdk)
+
+![PyPI - Downloads](https://img.shields.io/pypi/dm/tuya-iot-py-sdk)
+
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/tuya-iot-py-sdk)
+
+
+A Python sdk for Tuya Open API, which provides basic IoT capabilities like device management, asset management and industry capabilities, helping you create IoT solutions.
+With diversified devices and industries, Tuya Cloud Development Platform opens basic IoT capabilities like device management, AI scenarios, and data analytics services, as well as industry capabilities, helping you create IoT solutions.
+
+
+## Features
+### Base APIs
+- TuyaOpenAPI
+ - connect
+ - is_connect
+ - get
+ - post
+ - put
+ - delete
+
+- TuyaOpenMQ
+ - start
+ - stop
+ - add_message_listener
+ - remove_message_listener
+
+### APIs
+- TuyaDeviceListener
+ - update_device
+ - add_device
+ - remove_device
+
+#### Device control
+- TuyaDeviceManager
+ - update_device_list_in_smart_home
+ - update_device_caches
+ - update_device_function_cache
+ - add_device_listener
+ - remove_device_listener
+ - get_device_info
+ - get_device_list_info
+ - remove_device
+ - remove_device_list
+ - get_factory_info
+ - factory_reset
+ - get_device_status
+ - get_device_list_status
+ - get_device_functions
+ - get_category_functions
+ - get_device_specification
+ - send_commands
+
+#### Home
+- TuyaHomeManager
+ - update_device_cache
+ - query_scenes
+ - trigger_scene
+ - query_infrared_devices
+ - trigger_infrared_commands
+
+#### Assets
+- TuyaAssetManager
+ - get_device_list
+ - get_asset_info
+ - get_asset_list
+
+
+
+## Possible scenarios
+
+
+
+- [HomeAssistant Tuya Plugin](https://github.com/tuya/tuya-home-assistant)
+
+- [Tuya Connector Python](https://github.com/tuya/tuya-connector-python)
+
+- [FHEM Tuya Plugin by fhempy](https://github.com/dominikkarall/fhempy/tree/master/FHEM/bindings/python/fhempy/lib/tuya_cloud)
+
+- ...
+
+
+## Prerequisite
+
+### Registration
+
+Please check [Tuya IoT Platform Configuration Guide](https://developer.tuya.com/en/docs/iot/Configuration_Guide_custom?id=Kamcfx6g5uyot) to register an account on the [Tuya IoT Platform](https://iot.tuya.com?_source=github), and get the required information. You need to create a Cloud project and complete the configuration of asset, user, and application. Then, you will get the **username**, **password**, **Access ID**, and **Access Secret**.
+
+## Usage
+
+## Installation
+
+`pip3 install tuya-iot-py-sdk`
+
+## Sample code
+
+[OpenAPI Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/device.py)
+
+[Open IoT Hub Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/mq.py)
+
+## Tuya Open API reference
+
+Tuya opens up a variety of APIs covering business scenarios such as device pairing, smart home management, device control, and scene automation. You can call APIs according to API integration documents to implement applications.
+
+For more information, see the [documentation](https://developer.tuya.com/en/docs/cloud/?_source=github).
+<!-- [Documentation > Cloud Development > API Reference](https://developer.tuya.com/docs/iot/open-api/api-reference/api-reference) -->
+
+## Issue feedback
+
+You can provide feedback on your issue via **Github Issue** or [Technical Ticket](https://service.console.tuya.com/).
+
+## License
+
+tuya-iot-py-sdk is available under the MIT license. Please see the [LICENSE](./LICENSE) file for more info.
+
+
+
+
+%package help
+Summary: Development documents and examples for tuya-iot-py-sdk
+Provides: python3-tuya-iot-py-sdk-doc
+%description help
+# Tuya IoT Python SDK
+
+
+
+![PyPI](https://img.shields.io/pypi/v/tuya-iot-py-sdk)
+
+![PyPI - Downloads](https://img.shields.io/pypi/dm/tuya-iot-py-sdk)
+
+![PyPI - Python Version](https://img.shields.io/pypi/pyversions/tuya-iot-py-sdk)
+
+
+A Python sdk for Tuya Open API, which provides basic IoT capabilities like device management, asset management and industry capabilities, helping you create IoT solutions.
+With diversified devices and industries, Tuya Cloud Development Platform opens basic IoT capabilities like device management, AI scenarios, and data analytics services, as well as industry capabilities, helping you create IoT solutions.
+
+
+## Features
+### Base APIs
+- TuyaOpenAPI
+ - connect
+ - is_connect
+ - get
+ - post
+ - put
+ - delete
+
+- TuyaOpenMQ
+ - start
+ - stop
+ - add_message_listener
+ - remove_message_listener
+
+### APIs
+- TuyaDeviceListener
+ - update_device
+ - add_device
+ - remove_device
+
+#### Device control
+- TuyaDeviceManager
+ - update_device_list_in_smart_home
+ - update_device_caches
+ - update_device_function_cache
+ - add_device_listener
+ - remove_device_listener
+ - get_device_info
+ - get_device_list_info
+ - remove_device
+ - remove_device_list
+ - get_factory_info
+ - factory_reset
+ - get_device_status
+ - get_device_list_status
+ - get_device_functions
+ - get_category_functions
+ - get_device_specification
+ - send_commands
+
+#### Home
+- TuyaHomeManager
+ - update_device_cache
+ - query_scenes
+ - trigger_scene
+ - query_infrared_devices
+ - trigger_infrared_commands
+
+#### Assets
+- TuyaAssetManager
+ - get_device_list
+ - get_asset_info
+ - get_asset_list
+
+
+
+## Possible scenarios
+
+
+
+- [HomeAssistant Tuya Plugin](https://github.com/tuya/tuya-home-assistant)
+
+- [Tuya Connector Python](https://github.com/tuya/tuya-connector-python)
+
+- [FHEM Tuya Plugin by fhempy](https://github.com/dominikkarall/fhempy/tree/master/FHEM/bindings/python/fhempy/lib/tuya_cloud)
+
+- ...
+
+
+## Prerequisite
+
+### Registration
+
+Please check [Tuya IoT Platform Configuration Guide](https://developer.tuya.com/en/docs/iot/Configuration_Guide_custom?id=Kamcfx6g5uyot) to register an account on the [Tuya IoT Platform](https://iot.tuya.com?_source=github), and get the required information. You need to create a Cloud project and complete the configuration of asset, user, and application. Then, you will get the **username**, **password**, **Access ID**, and **Access Secret**.
+
+## Usage
+
+## Installation
+
+`pip3 install tuya-iot-py-sdk`
+
+## Sample code
+
+[OpenAPI Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/device.py)
+
+[Open IoT Hub Sample](https://github.com/tuya/tuya-iot-python-sdk/blob/master/example/mq.py)
+
+## Tuya Open API reference
+
+Tuya opens up a variety of APIs covering business scenarios such as device pairing, smart home management, device control, and scene automation. You can call APIs according to API integration documents to implement applications.
+
+For more information, see the [documentation](https://developer.tuya.com/en/docs/cloud/?_source=github).
+<!-- [Documentation > Cloud Development > API Reference](https://developer.tuya.com/docs/iot/open-api/api-reference/api-reference) -->
+
+## Issue feedback
+
+You can provide feedback on your issue via **Github Issue** or [Technical Ticket](https://service.console.tuya.com/).
+
+## License
+
+tuya-iot-py-sdk is available under the MIT license. Please see the [LICENSE](./LICENSE) file for more info.
+
+
+
+
+%prep
+%autosetup -n tuya-iot-py-sdk-0.6.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-tuya-iot-py-sdk -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.6-1
+- Package Spec generated