summaryrefslogtreecommitdiff
path: root/python-ufal-udpipe.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ufal-udpipe.spec')
-rw-r--r--python-ufal-udpipe.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-ufal-udpipe.spec b/python-ufal-udpipe.spec
new file mode 100644
index 0000000..ac7f8d4
--- /dev/null
+++ b/python-ufal-udpipe.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ufal.udpipe
+Version: 1.3.0.1
+Release: 1
+Summary: Bindings to UDPipe library
+License: MPL 2.0
+URL: https://ufal.mff.cuni.cz/udpipe
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/db/fd/69d78895fa80bb5acefac1976bb59158e68d5fe4a54b84494b82dfc7e13a/ufal.udpipe-1.3.0.1.tar.gz
+
+
+%description
+The ``ufal.udpipe`` is a Python binding to UDPipe library <http://ufal.mff.cuni.cz/udpipe>.
+The bindings is a straightforward conversion of the ``C++`` bindings API.
+In Python 2, strings can be both ``unicode`` and UTF-8 encoded ``str``, and the
+library always produces ``unicode``. In Python 3, strings must be only ``str``.
+
+%package -n python3-ufal.udpipe
+Summary: Bindings to UDPipe library
+Provides: python-ufal.udpipe
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-ufal.udpipe
+The ``ufal.udpipe`` is a Python binding to UDPipe library <http://ufal.mff.cuni.cz/udpipe>.
+The bindings is a straightforward conversion of the ``C++`` bindings API.
+In Python 2, strings can be both ``unicode`` and UTF-8 encoded ``str``, and the
+library always produces ``unicode``. In Python 3, strings must be only ``str``.
+
+%package help
+Summary: Development documents and examples for ufal.udpipe
+Provides: python3-ufal.udpipe-doc
+%description help
+The ``ufal.udpipe`` is a Python binding to UDPipe library <http://ufal.mff.cuni.cz/udpipe>.
+The bindings is a straightforward conversion of the ``C++`` bindings API.
+In Python 2, strings can be both ``unicode`` and UTF-8 encoded ``str``, and the
+library always produces ``unicode``. In Python 3, strings must be only ``str``.
+
+%prep
+%autosetup -n ufal.udpipe-1.3.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ufal.udpipe -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0.1-1
+- Package Spec generated