summaryrefslogtreecommitdiff
path: root/python-unbelipy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-unbelipy.spec')
-rw-r--r--python-unbelipy.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-unbelipy.spec b/python-unbelipy.spec
new file mode 100644
index 0000000..40baf1a
--- /dev/null
+++ b/python-unbelipy.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-unbelipy
+Version: 2.1.1b0
+Release: 1
+Summary: Asynchronous wrapper for UnbelievaBoat's API written in Python.
+License: MIT
+URL: https://github.com/chrisdewa/unbelipy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1f/b6/225530393ec13d625997fde269aa3cfb764b94416436fe8d771b23f9f256/unbelipy-2.1.1b0.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-aiolimiter
+Requires: python3-sphinx
+Requires: python3-sphinx-book-theme
+
+%description
+Asynchronous wrapper for UnbelievaBoat's API written in Python.
+
+%package -n python3-unbelipy
+Summary: Asynchronous wrapper for UnbelievaBoat's API written in Python.
+Provides: python-unbelipy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-unbelipy
+Asynchronous wrapper for UnbelievaBoat's API written in Python.
+
+%package help
+Summary: Development documents and examples for unbelipy
+Provides: python3-unbelipy-doc
+%description help
+Asynchronous wrapper for UnbelievaBoat's API written in Python.
+
+%prep
+%autosetup -n unbelipy-2.1.1b0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-unbelipy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1b0-1
+- Package Spec generated