summaryrefslogtreecommitdiff
path: root/python-untangle.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 18:07:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 18:07:44 +0000
commit552b65d6f7c51a2fac7f0fd755960ac876317b61 (patch)
treeec8d22a7e8317d23e3edd94f02933e4f1f9e6ebd /python-untangle.spec
parent63c47f3f4cc148c11fc1a8fdf6bbb871d166986f (diff)
automatic import of python-untangle
Diffstat (limited to 'python-untangle.spec')
-rw-r--r--python-untangle.spec100
1 files changed, 100 insertions, 0 deletions
diff --git a/python-untangle.spec b/python-untangle.spec
new file mode 100644
index 0000000..48f8d6e
--- /dev/null
+++ b/python-untangle.spec
@@ -0,0 +1,100 @@
+%global _empty_manifest_terminate_build 0
+Name: python-untangle
+Version: 1.2.1
+Release: 1
+Summary: Converts XML to Python objects
+License: MIT
+URL: https://pypi.org/project/untangle/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/69/4fbd17bc16143343c022d845fd0fc2fc3bd89f85a5dce897cf00ad2c0e70/untangle-1.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-defusedxml
+
+%description
+[![Build Status](https://github.com/stchris/untangle/actions/workflows/build.yml/badge.svg)](https://github.com/stchris/untangle/actions)
+[![PyPi version](https://img.shields.io/pypi/v/untangle.svg)](https://pypi.python.org/pypi/untangle)
+<a href="https://github.com/psf/black"><img alt="Code style: black" src="https://img.shields.io/badge/code%20style-black-000000.svg"></a>
+[Documentation](http://readthedocs.org/docs/untangle/en/latest/)
+* Converts XML to a Python object.
+* Siblings with similar names are grouped into a list.
+* Children can be accessed with ``parent.child``, attributes with ``element['attribute']``.
+* You can call the ``parse()`` method with a filename, an URL or an XML string.
+* Substitutes ``-``, ``.`` and ``:`` with ``_`` ``<foobar><foo-bar/></foobar>`` can be accessed with ``foobar.foo_bar``, ``<foo.bar.baz/>`` can be accessed with ``foo_bar_baz`` and ``<foo:bar><foo:baz/></foo:bar>`` can be accessed with ``foo_bar.foo_baz``
+* Works with Python 3.7 - 3.10
+
+%package -n python3-untangle
+Summary: Converts XML to Python objects
+Provides: python-untangle
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-untangle
+[![Build Status](https://github.com/stchris/untangle/actions/workflows/build.yml/badge.svg)](https://github.com/stchris/untangle/actions)
+[![PyPi version](https://img.shields.io/pypi/v/untangle.svg)](https://pypi.python.org/pypi/untangle)
+<a href="https://github.com/psf/black"><img alt="Code style: black" src="https://img.shields.io/badge/code%20style-black-000000.svg"></a>
+[Documentation](http://readthedocs.org/docs/untangle/en/latest/)
+* Converts XML to a Python object.
+* Siblings with similar names are grouped into a list.
+* Children can be accessed with ``parent.child``, attributes with ``element['attribute']``.
+* You can call the ``parse()`` method with a filename, an URL or an XML string.
+* Substitutes ``-``, ``.`` and ``:`` with ``_`` ``<foobar><foo-bar/></foobar>`` can be accessed with ``foobar.foo_bar``, ``<foo.bar.baz/>`` can be accessed with ``foo_bar_baz`` and ``<foo:bar><foo:baz/></foo:bar>`` can be accessed with ``foo_bar.foo_baz``
+* Works with Python 3.7 - 3.10
+
+%package help
+Summary: Development documents and examples for untangle
+Provides: python3-untangle-doc
+%description help
+[![Build Status](https://github.com/stchris/untangle/actions/workflows/build.yml/badge.svg)](https://github.com/stchris/untangle/actions)
+[![PyPi version](https://img.shields.io/pypi/v/untangle.svg)](https://pypi.python.org/pypi/untangle)
+<a href="https://github.com/psf/black"><img alt="Code style: black" src="https://img.shields.io/badge/code%20style-black-000000.svg"></a>
+[Documentation](http://readthedocs.org/docs/untangle/en/latest/)
+* Converts XML to a Python object.
+* Siblings with similar names are grouped into a list.
+* Children can be accessed with ``parent.child``, attributes with ``element['attribute']``.
+* You can call the ``parse()`` method with a filename, an URL or an XML string.
+* Substitutes ``-``, ``.`` and ``:`` with ``_`` ``<foobar><foo-bar/></foobar>`` can be accessed with ``foobar.foo_bar``, ``<foo.bar.baz/>`` can be accessed with ``foo_bar_baz`` and ``<foo:bar><foo:baz/></foo:bar>`` can be accessed with ``foo_bar.foo_baz``
+* Works with Python 3.7 - 3.10
+
+%prep
+%autosetup -n untangle-1.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-untangle -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.1-1
+- Package Spec generated