summaryrefslogtreecommitdiff
path: root/python-updates.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-updates.spec')
-rw-r--r--python-updates.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-updates.spec b/python-updates.spec
new file mode 100644
index 0000000..c7a7ab6
--- /dev/null
+++ b/python-updates.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-updates
+Version: 0.1.7.1
+Release: 1
+Summary: Check for updated packages in the PyPI
+License: MIT
+URL: https://github.com/fedosov/updates
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0d/6c/8cd5806fabb664e26aaaf99ab7d7a15ed0f6075bd5ef9749b03066a1f9ab/updates-0.1.7.1.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-updates
+Summary: Check for updated packages in the PyPI
+Provides: python-updates
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-updates
+
+
+%package help
+Summary: Development documents and examples for updates
+Provides: python3-updates-doc
+%description help
+
+
+%prep
+%autosetup -n updates-0.1.7.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-updates -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.7.1-1
+- Package Spec generated