summaryrefslogtreecommitdiff
path: root/python-uranium.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 17:49:34 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 17:49:34 +0000
commite8e7fd1f67300bfec64bc336b8fa81ba0880bdd3 (patch)
tree9d8bbce93373a4beb4c0f440b9d9608d0b0a0132 /python-uranium.spec
parent6606ff9a8b0a75c919e2b511efcf0c12f6483263 (diff)
automatic import of python-uranium
Diffstat (limited to 'python-uranium.spec')
-rw-r--r--python-uranium.spec110
1 files changed, 110 insertions, 0 deletions
diff --git a/python-uranium.spec b/python-uranium.spec
new file mode 100644
index 0000000..2d26eef
--- /dev/null
+++ b/python-uranium.spec
@@ -0,0 +1,110 @@
+%global _empty_manifest_terminate_build 0
+Name: python-uranium
+Version: 2.1.2
+Release: 1
+Summary: a build system for python
+License: MIT License
+URL: http://uranium.readthedocs.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/67/3c/af57777807d8b9bae610c1816070c9c3c903886095c575f73264e05a2f93/uranium-2.1.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-coloredlogs
+Requires: python3-deepmerge
+Requires: python3-docopt
+Requires: python3-packaging
+Requires: python3-pip
+Requires: python3-requests
+Requires: python3-setuptools
+Requires: python3-virtualenv
+
+%description
+Uranium: an assembly tool for python, in python.
+uranium is an assembly tool that facilitates reuse and allows
+for execution of arbitrary setup code for Python services. Examples
+include:
+* downloading and installing eggs in a sandbox (using virtualenv internally)
+* downloading remote configuration
+* providing a framework for assembly configuration (e.g. differences
+ between dev and test mode)
+* any other arbitrary tasks
+You can find out more here:
+http://uranium.readthedocs.org/en/latest/
+
+%package -n python3-uranium
+Summary: a build system for python
+Provides: python-uranium
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-uranium
+Uranium: an assembly tool for python, in python.
+uranium is an assembly tool that facilitates reuse and allows
+for execution of arbitrary setup code for Python services. Examples
+include:
+* downloading and installing eggs in a sandbox (using virtualenv internally)
+* downloading remote configuration
+* providing a framework for assembly configuration (e.g. differences
+ between dev and test mode)
+* any other arbitrary tasks
+You can find out more here:
+http://uranium.readthedocs.org/en/latest/
+
+%package help
+Summary: Development documents and examples for uranium
+Provides: python3-uranium-doc
+%description help
+Uranium: an assembly tool for python, in python.
+uranium is an assembly tool that facilitates reuse and allows
+for execution of arbitrary setup code for Python services. Examples
+include:
+* downloading and installing eggs in a sandbox (using virtualenv internally)
+* downloading remote configuration
+* providing a framework for assembly configuration (e.g. differences
+ between dev and test mode)
+* any other arbitrary tasks
+You can find out more here:
+http://uranium.readthedocs.org/en/latest/
+
+%prep
+%autosetup -n uranium-2.1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-uranium -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.2-1
+- Package Spec generated