summaryrefslogtreecommitdiff
path: root/python-vobject.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-vobject.spec')
-rw-r--r--python-vobject.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-vobject.spec b/python-vobject.spec
new file mode 100644
index 0000000..a439cbd
--- /dev/null
+++ b/python-vobject.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-vobject
+Version: 0.9.6.1
+Release: 1
+Summary: A full-featured Python package for parsing and creating iCalendar and vCard files
+License: Apache
+URL: http://eventable.github.io/vobject/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/ce/27c48c0e39cc69ffe7f6e3751734f6073539bf18a0cfe564e973a3709a52/vobject-0.9.6.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Parses iCalendar and vCard files into Python data structures, decoding the
+relevant encodings. Also serializes vobject data structures to iCalendar, vCard,
+or (experimentally) hCalendar unicode strings.
+
+%package -n python3-vobject
+Summary: A full-featured Python package for parsing and creating iCalendar and vCard files
+Provides: python-vobject
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-vobject
+Parses iCalendar and vCard files into Python data structures, decoding the
+relevant encodings. Also serializes vobject data structures to iCalendar, vCard,
+or (experimentally) hCalendar unicode strings.
+
+%package help
+Summary: Development documents and examples for vobject
+Provides: python3-vobject-doc
+%description help
+Parses iCalendar and vCard files into Python data structures, decoding the
+relevant encodings. Also serializes vobject data structures to iCalendar, vCard,
+or (experimentally) hCalendar unicode strings.
+
+%prep
+%autosetup -n vobject-0.9.6.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-vobject -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.6.1-1
+- Package Spec generated