summaryrefslogtreecommitdiff
path: root/python-walkdir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-walkdir.spec')
-rw-r--r--python-walkdir.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-walkdir.spec b/python-walkdir.spec
new file mode 100644
index 0000000..c85e9f5
--- /dev/null
+++ b/python-walkdir.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-walkdir
+Version: 0.4.1
+Release: 1
+Summary: Tools to manipulate and filter os.walk() style iteration
+License: Simplified BSD License
+URL: http://walkdir.readthedocs.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1d/9e/93f916bac3524398849d0ff351551cefa49a54d9da73dc68be6467ca0eb0/walkdir-0.4.1.tar.gz
+BuildArch: noarch
+
+
+%description
+walkdir is a simple set of iterator tools intended to make it
+easy to manipulate and filter the output of os.walk() in a way
+that is also easily applicable to any source iterator that
+produces data in the same format.
+It offers tools such as:
+- glob-style filtering for file and directory names
+- depth limiting for directory recursion
+- flattening of output into simple sequences of path names
+- detection of symlink loops when following symlinks
+
+%package -n python3-walkdir
+Summary: Tools to manipulate and filter os.walk() style iteration
+Provides: python-walkdir
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-walkdir
+walkdir is a simple set of iterator tools intended to make it
+easy to manipulate and filter the output of os.walk() in a way
+that is also easily applicable to any source iterator that
+produces data in the same format.
+It offers tools such as:
+- glob-style filtering for file and directory names
+- depth limiting for directory recursion
+- flattening of output into simple sequences of path names
+- detection of symlink loops when following symlinks
+
+%package help
+Summary: Development documents and examples for walkdir
+Provides: python3-walkdir-doc
+%description help
+walkdir is a simple set of iterator tools intended to make it
+easy to manipulate and filter the output of os.walk() in a way
+that is also easily applicable to any source iterator that
+produces data in the same format.
+It offers tools such as:
+- glob-style filtering for file and directory names
+- depth limiting for directory recursion
+- flattening of output into simple sequences of path names
+- detection of symlink loops when following symlinks
+
+%prep
+%autosetup -n walkdir-0.4.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-walkdir -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
+- Package Spec generated