summaryrefslogtreecommitdiff
path: root/python-walrus.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 10:24:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 10:24:42 +0000
commit3765cce367f56b0a55490e3d6c859590b8970afb (patch)
treedac2f776250efea1ccfd378e813ffbc0c0011e09 /python-walrus.spec
parent5e942c0b75bd848443edf45474048d77c3153fb1 (diff)
automatic import of python-walrus
Diffstat (limited to 'python-walrus.spec')
-rw-r--r--python-walrus.spec213
1 files changed, 213 insertions, 0 deletions
diff --git a/python-walrus.spec b/python-walrus.spec
new file mode 100644
index 0000000..0053a8c
--- /dev/null
+++ b/python-walrus.spec
@@ -0,0 +1,213 @@
+%global _empty_manifest_terminate_build 0
+Name: python-walrus
+Version: 0.9.2
+Release: 1
+Summary: walrus
+License: None
+URL: http://github.com/coleifer/walrus/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/ba/620f31d1e706aa6df33d9edd7974974a88c6bf4fe94c058cc5f08ae4644c/walrus-0.9.2.tar.gz
+BuildArch: noarch
+
+
+%description
+## Walrus
+
+![](http://media.charlesleifer.com/blog/photos/walrus-logo-0.png)
+
+Lightweight Python utilities for working with [Redis](http://redis.io).
+
+The purpose of [walrus](https://github.com/coleifer/walrus) is to make working
+with Redis in Python a little easier. Rather than ask you to learn a new
+library, walrus subclasses and extends the popular `redis-py` client, allowing
+it to be used as a drop-in replacement. In addition to all the features in
+`redis-py`, walrus adds support for some newer commands, including full support
+for streams and consumer groups.
+
+walrus consists of:
+
+* Pythonic container classes for the Redis data-types:
+ * [Hash](https://walrus.readthedocs.io/en/latest/containers.html#hashes)
+ * [List](https://walrus.readthedocs.io/en/latest/containers.html#lists)
+ * [Set](https://walrus.readthedocs.io/en/latest/containers.html#sets)
+ * [Sorted Set](https://walrus.readthedocs.io/en/latest/containers.html#sorted-sets-zset)
+ * [HyperLogLog](https://walrus.readthedocs.io/en/latest/containers.html#hyperloglog)
+ * [Array](https://walrus.readthedocs.io/en/latest/containers.html#arrays) (custom type)
+ * [BitField](https://walrus.readthedocs.io/en/latest/containers.html#bitfield)
+ * [BloomFilter](https://walrus.readthedocs.io/en/latest/containers.html#bloomfilter)
+ * [**Streams**](https://walrus.readthedocs.io/en/latest/streams.html)
+* [Autocomplete](https://walrus.readthedocs.io/en/latest/autocomplete.html)
+* [Cache](https://walrus.readthedocs.io/en/latest/cache.html) implementation that exposes several decorators for caching function and method calls.
+* [Full-text search](https://walrus.readthedocs.io/en/latest/full-text-search.html) supporting set operations.
+* [Graph store](https://walrus.readthedocs.io/en/latest/graph.html)
+* [Rate-limiting](https://walrus.readthedocs.io/en/latest/rate-limit.html)
+* [Locking](https://walrus.readthedocs.io/en/latest/api.html#walrus.Lock)
+* **Experimental** active-record style [Models](https://walrus.readthedocs.io/en/latest/models.html) that support persisting structured information and performing complex queries using secondary indexes.
+* More? [More!](https://walrus.readthedocs.io)
+
+### Models
+
+Persistent structures implemented on top of Hashes. Supports secondary indexes to allow filtering on equality, inequality, ranges, less/greater-than, and a basic full-text search index. The full-text search features a boolean search query parser, porter stemmer, stop-word filtering, and optional double-metaphone implementation.
+
+### Found a bug?
+
+![](http://media.charlesleifer.com/blog/photos/p1420743625.21.png)
+
+Please open a [github issue](https://github.com/coleifer/walrus/issues/new) and I will try my best to fix it!
+
+### Alternative Backends
+
+Walrus also can integrate with the Redis-like databases [rlite](https://github.com/seppo0010/rlite), [ledis](http://ledisdb.io/), and [vedis](http://vedis.symisc.net). Check the [documentation](https://walrus.readthedocs.io/en/latest/alt-backends.html) for more details.
+
+
+%package -n python3-walrus
+Summary: walrus
+Provides: python-walrus
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-walrus
+## Walrus
+
+![](http://media.charlesleifer.com/blog/photos/walrus-logo-0.png)
+
+Lightweight Python utilities for working with [Redis](http://redis.io).
+
+The purpose of [walrus](https://github.com/coleifer/walrus) is to make working
+with Redis in Python a little easier. Rather than ask you to learn a new
+library, walrus subclasses and extends the popular `redis-py` client, allowing
+it to be used as a drop-in replacement. In addition to all the features in
+`redis-py`, walrus adds support for some newer commands, including full support
+for streams and consumer groups.
+
+walrus consists of:
+
+* Pythonic container classes for the Redis data-types:
+ * [Hash](https://walrus.readthedocs.io/en/latest/containers.html#hashes)
+ * [List](https://walrus.readthedocs.io/en/latest/containers.html#lists)
+ * [Set](https://walrus.readthedocs.io/en/latest/containers.html#sets)
+ * [Sorted Set](https://walrus.readthedocs.io/en/latest/containers.html#sorted-sets-zset)
+ * [HyperLogLog](https://walrus.readthedocs.io/en/latest/containers.html#hyperloglog)
+ * [Array](https://walrus.readthedocs.io/en/latest/containers.html#arrays) (custom type)
+ * [BitField](https://walrus.readthedocs.io/en/latest/containers.html#bitfield)
+ * [BloomFilter](https://walrus.readthedocs.io/en/latest/containers.html#bloomfilter)
+ * [**Streams**](https://walrus.readthedocs.io/en/latest/streams.html)
+* [Autocomplete](https://walrus.readthedocs.io/en/latest/autocomplete.html)
+* [Cache](https://walrus.readthedocs.io/en/latest/cache.html) implementation that exposes several decorators for caching function and method calls.
+* [Full-text search](https://walrus.readthedocs.io/en/latest/full-text-search.html) supporting set operations.
+* [Graph store](https://walrus.readthedocs.io/en/latest/graph.html)
+* [Rate-limiting](https://walrus.readthedocs.io/en/latest/rate-limit.html)
+* [Locking](https://walrus.readthedocs.io/en/latest/api.html#walrus.Lock)
+* **Experimental** active-record style [Models](https://walrus.readthedocs.io/en/latest/models.html) that support persisting structured information and performing complex queries using secondary indexes.
+* More? [More!](https://walrus.readthedocs.io)
+
+### Models
+
+Persistent structures implemented on top of Hashes. Supports secondary indexes to allow filtering on equality, inequality, ranges, less/greater-than, and a basic full-text search index. The full-text search features a boolean search query parser, porter stemmer, stop-word filtering, and optional double-metaphone implementation.
+
+### Found a bug?
+
+![](http://media.charlesleifer.com/blog/photos/p1420743625.21.png)
+
+Please open a [github issue](https://github.com/coleifer/walrus/issues/new) and I will try my best to fix it!
+
+### Alternative Backends
+
+Walrus also can integrate with the Redis-like databases [rlite](https://github.com/seppo0010/rlite), [ledis](http://ledisdb.io/), and [vedis](http://vedis.symisc.net). Check the [documentation](https://walrus.readthedocs.io/en/latest/alt-backends.html) for more details.
+
+
+%package help
+Summary: Development documents and examples for walrus
+Provides: python3-walrus-doc
+%description help
+## Walrus
+
+![](http://media.charlesleifer.com/blog/photos/walrus-logo-0.png)
+
+Lightweight Python utilities for working with [Redis](http://redis.io).
+
+The purpose of [walrus](https://github.com/coleifer/walrus) is to make working
+with Redis in Python a little easier. Rather than ask you to learn a new
+library, walrus subclasses and extends the popular `redis-py` client, allowing
+it to be used as a drop-in replacement. In addition to all the features in
+`redis-py`, walrus adds support for some newer commands, including full support
+for streams and consumer groups.
+
+walrus consists of:
+
+* Pythonic container classes for the Redis data-types:
+ * [Hash](https://walrus.readthedocs.io/en/latest/containers.html#hashes)
+ * [List](https://walrus.readthedocs.io/en/latest/containers.html#lists)
+ * [Set](https://walrus.readthedocs.io/en/latest/containers.html#sets)
+ * [Sorted Set](https://walrus.readthedocs.io/en/latest/containers.html#sorted-sets-zset)
+ * [HyperLogLog](https://walrus.readthedocs.io/en/latest/containers.html#hyperloglog)
+ * [Array](https://walrus.readthedocs.io/en/latest/containers.html#arrays) (custom type)
+ * [BitField](https://walrus.readthedocs.io/en/latest/containers.html#bitfield)
+ * [BloomFilter](https://walrus.readthedocs.io/en/latest/containers.html#bloomfilter)
+ * [**Streams**](https://walrus.readthedocs.io/en/latest/streams.html)
+* [Autocomplete](https://walrus.readthedocs.io/en/latest/autocomplete.html)
+* [Cache](https://walrus.readthedocs.io/en/latest/cache.html) implementation that exposes several decorators for caching function and method calls.
+* [Full-text search](https://walrus.readthedocs.io/en/latest/full-text-search.html) supporting set operations.
+* [Graph store](https://walrus.readthedocs.io/en/latest/graph.html)
+* [Rate-limiting](https://walrus.readthedocs.io/en/latest/rate-limit.html)
+* [Locking](https://walrus.readthedocs.io/en/latest/api.html#walrus.Lock)
+* **Experimental** active-record style [Models](https://walrus.readthedocs.io/en/latest/models.html) that support persisting structured information and performing complex queries using secondary indexes.
+* More? [More!](https://walrus.readthedocs.io)
+
+### Models
+
+Persistent structures implemented on top of Hashes. Supports secondary indexes to allow filtering on equality, inequality, ranges, less/greater-than, and a basic full-text search index. The full-text search features a boolean search query parser, porter stemmer, stop-word filtering, and optional double-metaphone implementation.
+
+### Found a bug?
+
+![](http://media.charlesleifer.com/blog/photos/p1420743625.21.png)
+
+Please open a [github issue](https://github.com/coleifer/walrus/issues/new) and I will try my best to fix it!
+
+### Alternative Backends
+
+Walrus also can integrate with the Redis-like databases [rlite](https://github.com/seppo0010/rlite), [ledis](http://ledisdb.io/), and [vedis](http://vedis.symisc.net). Check the [documentation](https://walrus.readthedocs.io/en/latest/alt-backends.html) for more details.
+
+
+%prep
+%autosetup -n walrus-0.9.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-walrus -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.2-1
+- Package Spec generated