summaryrefslogtreecommitdiff
path: root/python-wiki.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-wiki.spec')
-rw-r--r--python-wiki.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-wiki.spec b/python-wiki.spec
new file mode 100644
index 0000000..e1ea4b7
--- /dev/null
+++ b/python-wiki.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-wiki
+Version: 0.9
+Release: 1
+Summary: A wiki system written for the Django framework.
+License: GPLv3
+URL: http://www.django-wiki.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5c/f2/654dbbb4a12daf98024810653b1666822f1e77b9b27aa869248385db73a9/wiki-0.9.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+Requires: python3-bleach[css]
+Requires: python3-tinycss2
+Requires: python3-Pillow
+Requires: python3-django-nyt
+Requires: python3-django-mptt
+Requires: python3-django-sekizai
+Requires: python3-sorl-thumbnail
+Requires: python3-Markdown
+Requires: python3-django-functest
+Requires: python3-pytest
+Requires: python3-pytest-django
+Requires: python3-pytest-cov
+Requires: python3-coverage
+Requires: python3-codecov
+Requires: python3-ddt
+Requires: python3-pytest-pythonpath
+Requires: python3-flake8
+Requires: python3-black
+Requires: python3-pre-commit
+Requires: python3-django-functest
+Requires: python3-pytest
+Requires: python3-pytest-django
+Requires: python3-pytest-cov
+Requires: python3-coverage
+Requires: python3-codecov
+Requires: python3-ddt
+Requires: python3-pytest-pythonpath
+Requires: python3-flake8
+Requires: python3-black
+Requires: python3-pre-commit
+Requires: python3-transifex-client
+
+%description
+|Docs| |Build Status| |Coverage Status| |PyPi| |Downloads| |IRC|
+
+%package -n python3-wiki
+Summary: A wiki system written for the Django framework.
+Provides: python-wiki
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-wiki
+|Docs| |Build Status| |Coverage Status| |PyPi| |Downloads| |IRC|
+
+%package help
+Summary: Development documents and examples for wiki
+Provides: python3-wiki-doc
+%description help
+|Docs| |Build Status| |Coverage Status| |PyPi| |Downloads| |IRC|
+
+%prep
+%autosetup -n wiki-0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-wiki -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9-1
+- Package Spec generated