summaryrefslogtreecommitdiff
path: root/python-win-unicode-console.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 05:10:52 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 05:10:52 +0000
commitdeb3f4dc194cf26d4a29660906bded32582ccc3e (patch)
tree07a3c40bb6c02ed5c30a9f2dd159655d5d0d91c3 /python-win-unicode-console.spec
parentb8e40cba4d037c4382df47daef93ea4aa5d76075 (diff)
automatic import of python-win-unicode-console
Diffstat (limited to 'python-win-unicode-console.spec')
-rw-r--r--python-win-unicode-console.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-win-unicode-console.spec b/python-win-unicode-console.spec
new file mode 100644
index 0000000..6d898f3
--- /dev/null
+++ b/python-win-unicode-console.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-win_unicode_console
+Version: 0.5
+Release: 1
+Summary: Enable Unicode input and display when running Python from Windows console.
+License: MIT
+URL: https://github.com/Drekin/win-unicode-console
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/89/8d/7aad74930380c8972ab282304a2ff45f3d4927108bb6693cabcc9fc6a099/win_unicode_console-0.5.zip
+BuildArch: noarch
+
+
+%description
+A Python package to enable Unicode input and display when running Python from Windows console.
+
+%package -n python3-win_unicode_console
+Summary: Enable Unicode input and display when running Python from Windows console.
+Provides: python-win_unicode_console
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-win_unicode_console
+A Python package to enable Unicode input and display when running Python from Windows console.
+
+%package help
+Summary: Development documents and examples for win_unicode_console
+Provides: python3-win_unicode_console-doc
+%description help
+A Python package to enable Unicode input and display when running Python from Windows console.
+
+%prep
+%autosetup -n win_unicode_console-0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-win_unicode_console -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5-1
+- Package Spec generated