summaryrefslogtreecommitdiff
path: root/python-workday.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-workday.spec')
-rw-r--r--python-workday.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-workday.spec b/python-workday.spec
new file mode 100644
index 0000000..49fa2fc
--- /dev/null
+++ b/python-workday.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-workday
+Version: 0.4.0
+Release: 1
+Summary: Python client for Workday tenants
+License: Apache License (2.0)
+URL: https://github.com/tonybaloney/workday
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4c/4c/c488b0bcefdad0efcd70f8d0950f4aff18661ae4a3914de2c7fcbbe56b5f/workday-0.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-zeep
+Requires: python3-requests
+Requires: python3-six
+
+%description
+
+
+%package -n python3-workday
+Summary: Python client for Workday tenants
+Provides: python-workday
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-workday
+
+
+%package help
+Summary: Development documents and examples for workday
+Provides: python3-workday-doc
+%description help
+
+
+%prep
+%autosetup -n workday-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-workday -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated