summaryrefslogtreecommitdiff
path: root/python-wxbtool.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-15 05:46:36 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-15 05:46:36 +0000
commitbee48dce495a95125ce0bcaf375acbdf35be950b (patch)
tree1aca3dbba22800ab8fb436e4793493d3bd254f3d /python-wxbtool.spec
parentf5bf419d1297ba1030b3a0b50ead8d9a06d78416 (diff)
automatic import of python-wxbtool
Diffstat (limited to 'python-wxbtool.spec')
-rw-r--r--python-wxbtool.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-wxbtool.spec b/python-wxbtool.spec
new file mode 100644
index 0000000..7046f0c
--- /dev/null
+++ b/python-wxbtool.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-wxbtool
+Version: 0.0.61
+Release: 1
+Summary: A toolkit for WeatherBench based on PyTorch
+License: MIT License
+URL: https://github.com/caiyunapp/wxbtool
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/96/a7/bd59e6143e60f34de57938caab07d570c60671185c4ca63d6e6dcbc11c77/wxbtool-0.0.61.tar.gz
+BuildArch: noarch
+
+Requires: python3-torch
+Requires: python3-numpy
+Requires: python3-netcdf4
+Requires: python3-toolz
+Requires: python3-dask
+Requires: python3-xarray
+Requires: python3-opencv-python
+Requires: python3-arrow
+Requires: python3-decouple
+Requires: python3-leibniz
+Requires: python3-flask
+Requires: python3-msgpack
+Requires: python3-msgpack-numpy
+Requires: python3-requests
+Requires: python3-gunicorn
+Requires: python3-arghandler
+
+%description
+```bash
+pip install wxbtool
+```
+
+%package -n python3-wxbtool
+Summary: A toolkit for WeatherBench based on PyTorch
+Provides: python-wxbtool
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-wxbtool
+```bash
+pip install wxbtool
+```
+
+%package help
+Summary: Development documents and examples for wxbtool
+Provides: python3-wxbtool-doc
+%description help
+```bash
+pip install wxbtool
+```
+
+%prep
+%autosetup -n wxbtool-0.0.61
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-wxbtool -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.61-1
+- Package Spec generated